All ads are not being blocked

On 16/7/2023, I accidentally shut-down my PC, causing my computer to update their OS (I have been avoiding the update by putting my computer to Sleep every time). After I turn on my PC again, everything worked just fine, but my PC crashed after 5 minutes. I turned it on again now my Brave browser is hay-wired. There are ads playing for every site that I visited.

The 3 main websites I frequently visited :

redirect and pop up ads common in these type sites

ads before a video


Did the issue present with default Shields settings?
The issue still persisted when after following this forum ( see last screenshot )

Does the site function as expected when Shields are turned off?
If this means can I use it while seeing ads, yes the sites worked just fine

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration.
No I dont think so. Ive never touched Shields configuration until the issues happened.

Does the site work as expected when using Chrome?

Brave :
Version 1.52.130 Chromium: 114.0.5735.198 (Official Build) (64-bit)

Windows 11 Home, Version 22H2, OS Build 22621.1848

For added context, I have tried rolling back my windows update but the issue still persisted. I have tried clearing my cache and cookies but nothing happened. I have check with my friend, and it seemed that he has the exact same version of Brave as I do and he does not have this issue.

Please man I’ve promoted your browser to every person that I talked to whenever topic of browsers came up. I swear man Ive converted soo many people into using Brave. I dont want to start using OperaGX man, Brave is too good.

Thank you for the reply but Im going to be honest, I have no idea what you are trying to say.

Ive checked the brave://components/ before I write this forum and Ive already check for update for everything in it. I have also checked Brave Ad Block Updater - Version: and it is up to date. However if it is “to see if your lists are being downloaded.” I have no idea how to check that or do that or what it means. Is “the list”, the 3 websites I said I frequent?

As for the localappdata thing, Ive checked it and its blank. Once again I have no idea what you are trying to say with “default list”

should I copy paste the content in the GitHub list youve given me into the blank list.txt file?

Im so sorry that I didnt understand you, Im not technologically savvy.

Well, the list.txt has more than 125K rules on it, a lot of text, so did you never see any content being rendered in Notepad??
because if it was empty, I wouldn’t see a 4 in the size (in your screenshot) and in my case it is 4,443KB here in my computer, which would explain why it says 4 but not why it is blank, unless it was too much text for Notepad to open it.

But if it was empty, that will be the reason why it is not blocking anything, adblockers need rules, each rule will tell the adblocker what to do, if the file was empty when you opened like your screenshot and nothing ever appeared, that will be the reason.

In any case, just delete that 1.0.372 folder and restart Brave so the lists get downloaded again. That might fix it, but when you restart brave and you see the folder being re-created again, open list.txt again and see if now it is not empty, because it is weird it is empty but still not 0KB for example.

Also go to brave://settings/shields and make sure Adblocker is set to Aggressive, just because the Default is Standard and that doesn’t do all the job the adblocker could.

If nothing works, download and test using this list.txt and see if replacing the txt that is empty will fix the issue, hoping next lists download properly.

About the default.json, well, that will be a last resort if nothing works, but you just take the "url": information like: and add them in the custom filters section in brave://settings/shields/filters, which will not have any issues in the future because the lists update directly from the servers of the list maintainers, the only issue is you pretty much have to take some time sometimes to update the lists (Expires property is only supported in Nightly), because they update every 7 days. But you will not have any issues anymore.


But I am sure just re-downloading the lists will fix it, so do that first.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.