Brave adblocker not working

AdBlocker not working.
Exact URL of the website in question:
Any site with ads

Screenshot of the ad as it appears in Brave
Screenshot from 2021-08-28 22-39-48|690x375
Did the issue present with default Shields settings ? (yes/no)

Does the site function as expected when Shields are turned off?

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):

Does the site work as expected when using Chrome?
I don’t use Chrome
Brave version (check About Brave ):
Version 1.28.106 Chromium: 92.0.4515.159 (Official Build) (64-bit)

Brave is currently beta so there might be issued with adblocking,
and also some ads may have a different scripts, like youtube. you can turn off scripts but MAY break.

It is not just youtube, adblocker is not working on every site that has adds.

1 Like


Follow the instructions from the thread below to re-download the ad block component.


@Rethanis Thanks for the help!


Can you please confirm whether or not updating the ad-block component resolved he issue for you?

@Mattches I tried to update ad-block component but I couldn’t, maybe it’s already the latest version. I tried the solution suggested by @Rethanis. It worked!

1 Like

Thank you for confirming. Please don’t hesitate to reach out if you have any futher questions or concerns.