Brave on Mac now constantly crashing

Brave has been very stable since I started using it several months ago. Two days ago it started crashing every 30 mins or so. Extremely frustrating. I haven’t changed anything about my computer.

Anyone else having this problem?

1 Like

I do. And I can’t identify anything in particular that causes it.

1 Like

@garicruze @vdb did you have Sync enabled?

I don’t have sync enabled. Or at least I don’t think so.

I have (for over a year) two profiles (Brave calls them “people” or “persons”), one for work and one for personal, so in fact I always have two windows open within Brave and switch between them frequently. The bookmarks are synched between each other. I have three extensions active: Reader View, Bitwarden and Wallabag. Everything (browsers and extensions) is updated to the latest version.

Interesting… what version of mac do you have and what version of Brave browser do you have ?

Similar problem. I downloaded Brave yesterday, so it’s the latest version. Imported bookmarks from my old browser, opened Sync, and turned off Rewards. Everything ran smoothly, so I quit the app. A few hours later, I opened Brave again, and it froze almost immediately. Force quitting and reopening the app didn’t help. Today I tried it a couple more times, restarted my Mac, deleted and downloaded the browser again, but the problem persists.

After looking at other crashing reports by Windows users, my guess is that Brave is having trouble syncing my data. And there’s no way for me to turn sync off, because the browser freezes before I can even move my finger.

To be fair, my MacBook Pro is old, but it’s in pretty good condition, and hasn’t had any problem processing browsers with many, many tabs open. Other browsers I use carry the same amount of data to sync and are all working fine. Clarification: I did quit all other apps when trying to open each browser, and only Brave crashes.

Yes, started couple days ago. Seems random. Macos 10.14.6 and Brave 68.142

You can launch Brave with Sync disabled from the command line or issuing command line flags in the desktop shortcut. Try the following:

  1. Find the shortcut you use to open Brave, Right-click --> Properties
  2. In the Target field, add --disable-brave-sync to the end of the text string.
  3. Apply --> OK then launch Brave.

Let me know the results.

I’m using a Mac and don’t have shortcuts. Brave preferences don’t show
sync set up and I’ve never tried to sync bookmarks. Is there an option to
disable synch on a ZMac?

Macos 10.14.6 and Brave 68.142 crashing also! Can’t find a fix.

Try launching Brave from the Terminal with the flag appended using the following command (for macOS):
/Applications/ --disable-brave-sync

Latest versions of software (macOS and brave)

Brave 0.68.138 Mac OS 10.12.6
I’ve been using brave for a few months on this computer without it ever crashing. After the most recent update the browser has crashed a few times and the overall experience seems slower. Also feels like it’s jamming the computer up too, like spotlight to terminal to run the following command took ages to find/open terminal, likewise it stalled going to the apple/about to get OS version.

I’m happy to allow crash logs to be shared with you, just give me the cmd for terminal to get it done.

/Applications/ --disable-brave-sync

-bash: /Applications/ No such file or directory

Edit: I should add that it’d only been a couple of hours since I updated. And damn it’s so slow, almost like the browser freezes every time I open a new page (within reddit) until that page’s data finishes loading, and considering I rely on a 3g hotspot, this current update is a good example of why I usually avoid updating, why did I click ok this time? Did it even give me an option?

Also computer fan is running alot more, it keeps having bursts when all i’m doing is browsing reddit and the temp is cool. This ain’t right…

Edit 2: I’ve gone back to Firefox and the experience is so much better, no freezing and no fan bursts.

2017 MacBook Pro using iOS 10.14.6 and Brave Version 0.68.142 Chromium: 77.0.3865.90 (Official Build) (64-bit)

I see that you – if I’m understanding correctly – have already tried disabling Sync to try and resolve the issue? It looks like you have an error showing in that terminal command:

Can you elaborate on whether or not you were able to get the command to work and if it had any effect? Additionally, can you please update to the latest version – v0.68.142 at the time of writing this – as we’ve included some fixes that will resolve crashes for some users/some cases?

I never had sync activated so there was no way to disable it.

Brave stated that 0.68.38 was upto date and there was no way to update it so I downloaded a new install package. The new one says 0.68.142 is upto date. I will use now and if the issues persist, I will let you know.

Thanks for responding :slight_smile:

Edit: 0.68.142 after a couple hours of use it appears as though it works well again , there’s no freeze-loading nor are there any fan bursts.

1 Like

I just updated to the latest version of Brave and the crashing continues. Putting “/Applications/ --disable-brave-sync” into the terminal on Mac gets the same result as @ downloadlimited, i.e. “-bash: /Applications/ No such file or directory”.

Then I tried to disable sync through my mobile app, removing all my devices, so now there’s no more syncing. However, the desktop app continues to freeze 10 seconds after it launches.

That’s my fault – I think I gave the wrong path. Try the following:
/Applications/Brave\\ Browser --disable-brave-sync

1 Like

This worked, thank you very much.

However, if I try to open the browser through the regular way (i.e. clicking on the icon), it would freeze again after a few seconds. Does this mean I have to use the terminal command every time from now on?