Brave Browser Crashes On MacOS About 2 Minutes After Startup

Hi, i have been having issues with brave browser on macOS, I can start it up fine but about 2 minutes later it will just crash. This started happening to me a few days ago.
I’ve tried to uninstall and reinstall to no effect, disabling hardware acceleration seems to have no effect as well.
Heres a link to the latest crash report:
https://pastebin.com/PhqxzSjV

Hi!

I got exactly the same issue on my MS Surface working on latest Win10.

Wersja 0.68.141 Chromium: 77.0.3865.90 (Oficjalna wersja) (64-bitowa)

Brave on my desktop PC (Win10 as well) works fine.

Cheers!

Zen

@ReduX

Do you syncronize bookmarks etc?

Today I made some changes in bookmarks on my desktop and now I’ve found that it doesn’t sync them on my Surface. Of course Brave crashed (that’s why I wrote previous post). Then I turned off syncing and Brave works…

Anyway, it doesn’t solve my problem :confused:

Someone told me to disable hardware acceleration leave the sync chain and that has actually worked for me now brave does not crash anymore so try that and see if that does anything.

@zenzmyler,
Try leaving the Sync chain as @ReduX suggests – its currently a known issue causing crashes:

1 Like

@ReduX
Yeap! It worked for me too! Thanks!

@Mattches
So should we wait for another update and then check if acceleration works?

I’m getting a similar problem, though I don’t have the big section of code like you do. Brave has been giving me the spinning wheel of death on my mac multiple times today, and locks up my computer so I have to restart.

What’s the deal?

My Mac Mini and laptop do the same thing using Macos 10.14.6 and Brave 68.142