Brave "notification" cannot be dismissed except by reboot


Description of the issue:
I’m not exactly sure what you officially call it but ON SEVERAL OCCASIONS Brave generates a “notification”/“alert”/“control” which appears above the default network control panel and has NO option to dismiss. It appears to be a combined alert and control for a YouTube video because it always has the title & channel name of a video I have watched on YouTube and it has control buttons for rewind, play, and forward (none of which actually work).

How can this issue be reproduced?
I have no idea how these alerts are being created in the first place (other that they are randomly occurring when websurfing on YouTube) but the one thing that is reproducible is that once an alert like this shows up two things are constant: (1) quitting Brave does NOT eliminate it - even killing all Brave related processes in Task Manager does not make it go away, and (2) the ONLY way to eliminate the alert is to do a full reboot of the computer.

Expected result:
I expect that any dialog window should have some user control to close or dismiss it. Whatever this little alert is called, Brave needs to fix it so I can click an “X” or “Dismiss” button. I do NOT expect to have to reboot just to dismiss an alert.

Brave Version( check About Brave):
Version 1.41.100 Chromium: 103.0.5060.134 (Official Build) (64-bit)

Additional Information:
Running up to date version of Windows 11. I am including an image of the alert to clarify (personal info has been redacted):

Hi and welcome to the community. Really can’t help with your issue. Just wondering if you’ve tried using other chromium based browsers to test if this is only a Brave issue. I’m wondering if this is a system settings problem vs a Brave problem.

You can also test to see if problem still occurs when browsing the site:

  1. in a new private window (Ctrl-Shift-N)
  2. in a new profile ( Create a new profile to help Troubleshoot)
  3. in Brave Beta and/or Nightly

This is a Windows feature that is not specific to Brave. That said, I believe this falls under the “Hardware Media keys handling” flag which should stop it form occurring in Brave. Please try the following:

  1. Launch Brave
  2. Go to brave://flags
  3. Search for a flag called Hardware Media Key Handling
  4. Set the flag value to Disabled
  5. Relaunch the browser

Now revisit Youtube and test again — the media bar in the system tray should no longer appear. Please let me know if this works for you.

1 Like