Media controls Brave tabs instead of Spotify

bug
#1

Description of the issue:

The problem listed in the title started today. I’m not sure of any updates to the Brave browser or anything else in my system. I am using a wireless Logitech G602 and mapping the side buttons to control the media player in the Logitech software.

This happens when Brave is the active window and when it is not.

Brave Version(See the About Brave page in the main menu):

0.61.51 ( official build)

Thank you for any help with this.

4 Likes

#2

Confirming this and it’s driving me crazy. Is this by design or a bug? I can’t use Brave anymore in this state.

EDIT: This bug only happens after opening a tab containing multimedia buttons. So a Youtube video will lock my Foobar2000 out of my keyboard’s media buttons. The huge, glaring bug is that Brave will retain control of my keyboard’s buttons even after closing all Youtube tabs, essentially making them 100% useless. Only closing all Brave windows will give back control to other programs.

So it seems to be a “feature.” Please, don’t you ever, ever globally alter our OS’s environments again and if you want to do so provide a clear setting to disable it.

3 Likes

#3

So it seems to be a “feature.”

I’m not sure what kind of feature that would be! I’ll be sure to get this issue logged for the devs to see. Thank you both for bringing this to our attention.

3 Likes

#4

Same problem, do we just wait for Brave to fix it or have you people found any other solution?

1 Like

#5

Is it only with Logitech Mouses? Can someone with another brand see if this bug happens to them too?

0 Likes

#6

Mouses? We are talking about Media Buttons on Keyboard, i have Razer and i have the problem!

0 Likes

#7

My laptop does not have media control buttons so I have mapped my mouse to control them. Its mapped using the Logitech software so I’m not sure how it is doing it but I would assume that it is the command being sent as the keyboard media control keys.

0 Likes

#8

@Cloaking and anyone watching this thread,

I’d like to consolidate and get some confirmed data on this issue and what may be causing it on [all of] your machines. If you don’t mind – even if you’ve already provided it – if you’re encountering this error, please reply to this thread with the following information:

  • Which channel installation (Release, Beta, Developer) and Brave version you’re using
  • Whether you’re using a laptop or desktop w/connected keyboard with media buttons
  • Any additional software you have to facilitate or enable media/keyboard controls
  • Any information about your setup that may be “unique” to others

This data will help build a case on this issue and give devs the most accurate and relevant data so a fix can be efficiently implemented.

2 Likes

#9
  1. Which channel installation (Release, Beta, Developer) and Brave version you’re using

    • Version 0.61.51 Chromium: 73.0.3683.75 (Official Build) (64-bit)
  2. Whether you’re using a laptop or desktop w/connected keyboard with media button

    • Using a MSI GS65 - No Media Buttons
  3. Any additional software you have to facilitate or enable media/keyboard controls

    • Using Logitech Gaming Software 9.02 to enable media control on a Logitech g620 Mouse
1 Like

#10
  1. Version 0.61.51 Chromium: 73.0.3683.75 (Official Build) (64-bit)
  2. Desktop with connected keyboard with media buttons
  3. Media buttons does not require Razer Synapse so i guess no.
  4. No, standard desktop
2 Likes

#11

I believe you’re looking way too much into it. These multimedia keys are a (somewhat) standard feature since at least Windows 98. Nothing special about brands or models.

Anyway, it seems this is a feature introduced in Chrome 73:

The captured key is very likely this one: VK_MEDIA_PLAY_PAUSE (Value: 0xB3)
Reference: https://docs.microsoft.com/en-us/windows/desktop/inputdev/virtual-key-codes

Here’s my setup:
Release channel - Version 0.61.51 Chromium: 73.0.3683.75 (Official Build) (64-bit) - Windows 7
Desktop with media buttons
No additional software
Nothing unique - Using a DasKeyboard

1 Like

#12

I found the solution. Go to brave://flags

Search for “Hardware Media Key Handling” and make sure it’s set to disabled.
Restart Brave.

2 Likes

#13

That worked for me! Thanks a lot!

1 Like

#14

This should be in preferences. Thank You Very Much

2 Likes

#15

@epremuz,
Excellent find – this is great to know. Thank you for your assistance – I’ll be passing this information to the team so that we can incorporate this (ideally) into Settings in future releases as @szpieg mentioned.

1 Like

closed #16
0 Likes