Clicking hyperlink in email renders Application not Found error

Description of the issue:
Initially when I clicked on a hyperlink in an outlook email a blue circle would appear and spin briefly but the web page never opened, so I had to set default browser to Firefox, which worked. After reading up on this issue, it looked as though I had an old Brave instance (Brave appeared twice under apps in windows 10 settings). I deleted what appeared to be the older app and now when I click on a hyperlink I get an Application not found error. I have changed the default browser to FF and then back Brave hoping to connect with the current version of Brave, but no change - still throwing an error.
How can this issue be reproduced?

1.Click on a hyperlink in an outlook email or any hyperlink residing outside of the Brave browser

Expected result:
hyperlinked webpage should open in Brave
Brave Version( check About Brave):
Additional Information:

Thank you for reaching out.
Can you try changing the associated app with the .html filetype to Brave? In Windows, use the search bar and open the Choose default apps by file type option. Search for .html files and set this to Brave – if it’s already set as Brave, go ahead and change it to something else, then back again and see if this does the trick.

I tried that once before, but did it again and it still shows application not found. oddly under “Set defaults by App” Brave is listed twice

If you click on them, what version is shown?

No version just a manage button
Capture manage
under Apps only one instance listed where version number is visible

Oddly…before I deleted the old version of Brave three brave.exe files appeared when I searched on Brave, now not a single brave.exe appears, just the install exe.

So in Windows, the new version of Brave and it’s data is found in

C:\Users\[your user name]\AppData\Local\BraveSoftware

However, the old version and data is found in

C:\Users\[your user name]\AppData\Local\brave

I see in your image there that the old version of the browser seems to still have some lingering data associated with it. I’m wondering if the system is holding some reference to that data which gives the error. Can you try fully deleting anything found in C:\Users\[your user name]\AppData\Local\brave and then test again?

I can, this is what the folder contains
brave folder

still same issue. I deleted the update.exe not the .dead file - should I?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.