Brave not seeing secure connection

Hello All,

Why us Brave not seeing HTTPS sites first time around? When I get this screen, I need to push “continue to site” to move on. Once done, it then successfully sees the HTTPS version.


1 Like

I’m not having that issue on mine and I’d question what you’re accessing, as that’s trying to tell you it doesn’t support HTTPS, which Amazon does support. It makes it seem like it’s routing you to a fake site or something and trying to reduce your security.

Either way, what version of Brave are you using and what OS? I doubt extensions would be doing anything, but have you tried toggling them off first and then going to it?

Again, my issue is I go to Amazon on Android, iPhone, and Windows but never received that message…yet I have my Brave Shields set at the default, which always upgrades to HTTPS.

Win7x64, and Brave automatically updates to the latest, so…
Version 1.35.103 Chromium: 98.0.4758.102. Will look into the extensions.

This isn’t just Amazon, and it doesn’t happen every time. Clicking continue usually works, but not always. I do use PIA VPN and have had some issues with some sites (depending on traffic?) throwing up an “ERR_CONNECTION_TIMED_OUT” message, including Amazon right now. If I disconnect from the VPN, it works fine. There aren’t many PIA servers I can use, as most of them deny my e-mail server so I’m stuck using Denver for now…



Just to make sure I’m reading and understanding that right, are you saying the notice in your original post only happens when you’re on VPN?

If so, I guess that’s part of what’s happening but then my limited knowledge no longer becomes useful because I’d have no idea what changes to make or anything. If not, then that brings us back to having to figure out the cause. A lot of that will be up to staff and better experts. I just usually go through and try to help people with the basics, while also trying to get key info so others can better assist.

There are several sites I can access by filling out a “captcha” and others only by disconnecting but I’d rather it stay in place unless need be. I’ve been using PIA for 3 years now, and this issue has just popped up over the last month or so, so I can’t help but think it’s something “laggy” in Brave. I say laggy because at first, I’d do nothing and it would load the site after a few secs, but now I’m needing to press the “continue” button or it just sits there until I do.



A similar issue I had filled few months back Certificate/https error while visititng sites

If I search a completely new site (which I never have before) directly into the URL bar, I get this same error. Every time then I have to click on continue to site.
It has happens both on Desktop and on android. Everything is fine on my end. Other browser I have on my desktop and android never gave me this error (on multiple OS).

In my post, I said that it had been solved, but it never got completely. I am 99% sure the problem is on Brave’s end (browser)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.