When I visit a "https" website, it keeps dropping back to "http" while on Brave

Description of the issue: HTTPS website keeps dropping to Unsecured HTTP
How can this issue be reproduced?

  1. When I visit a https website, even though under the shield, i have the “Connection Upgrade to https” turned ON, it frequently keeps dropping back to unsecured http.
  2. is brave browser compromised?
  3. I have the latest update. reinstalled multiple times by cleaning all traces of brave on my mac from library, application support, preferences, saved sessions, caches etc.

Expected result:
I expect brave to refresh and upgrade to https rather staying in http when I have the slider ON to “Connection upgraded to https”

Brave Version( check About Brave): v1.16.76

Additional Information: https://www.ignitioncasino.eu/

try on a private window and does it stop? If yes, then it points to a naughty extension…

If no, what’s the site that’s doing this?


i tried on a private window. The slider on the “scripts blocked” doesn’t turn on, for every click, it says on the grey left side. Updated the website name on the post.

Seems like it’s fine to me… Try to clear you cache and cookies, turn off extensions, etc…

its after u login and use the website, it keeps falling back every 30 mins

Still looks fine to me…

edit: wait for 30 minutes? hrmmm…

that’s correct, notice how it says “Not Secure” when you visit the site and login. Imagine you are in a game, a bad actor can not only read the images on the website, but, they can also modify or replace with their own which is a huge security vulnerability (millions $).
Try changing the slider on scripts blocked or upgrade to https, it kicks back or doesn’t change which is strange.

30min+ and still logged in to https… I’ll stay logged in and see again. in another 30… but either way your issue is odd… no idea where to even start, especially if i can’t repro the issue… maybe turn off shields off completely… sometimes fingerprinting can break sites, so maybe try allow all fingerprinting… but then again, i haven’t reproduced the issue with fingerprinting on…

Did it happens on other browsers, @BreamHallVC ? Most likely it’s because some contents loaded from http – 2nd screenshot from @megaspaz show it’s https with Not secure message (mixed content, possibly). You can ask the site owner about that too.

This setting works if the site is support https but loaded via http. So Brave will try to “upgrade” the traffic only if it’s possible/supported.

Still no downgrade to http… I opened a game and left it open for 30 min… got told i’m in danger on of being logged out of game so i reloaded the game… still https… can’t repro the issue…

play game, switch, play again, menu, launch poker, launch casino, between many option switching, i noticed, it keeps dropping to http. based on comments above, i tried it on firefox and i noticed the same issue

sounds like the site’s issue then… that’s pretty heinous reproduction steps…

1 Like

appreciate the effort thank you, i will check with site admin

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.