Establishing Secure Connection forever

Hello! I really like the Brave Browser, but I have been having problems with it ever since I downloaded it. I am having a problem where after browsing webpages for a bit, I will get to a point where the webpage no longer loads and in the bottom left it says “Establishing Secure Connection”. This lasts on screen for about a minute before it disappears and nothing loads.
Any attempts to open any other web pages do not load, or only partly load after a minute.
Refreshing or opening a new window does not work. The only solution I have found is to exit out of Brave and wait 15 seconds before re-opening it, or else the problem will persist if opened too early.
I can not say how this happens, but it seems to happen after browsing for a bit or opening to many tabs. Before it happens, it seems like the pages load somewhat slower for a bit.
I have tried ;
-disabling hardware acceleration
-deleting all cookies, cashes, and history
-disabling all extensions
-using private windows
-disabling https upgrades
None of this seems to work as it happens on every site randomly. It seems to happen after 10 minutes or so of browsing, sometimes less. The only thing I can do is close all web pages and wait for a bit before re-opening the browser again if I want to fix it.
Here is an example picture of what I normally get, a blank screen with Establishing Secure Connection in the bottom left forever.


And here is an example of what it looks like when in the rare occasions, it partly loads some parts of a webpage after 1 minute.

I am using Windows 10, Intel Core i7-6700k CPU @ 4.00GHz, 16gb Ram, 64 bit operating system and processor.
Brave Version : Version 0.65.118 Chromium: 75.0.3770.80 (Official Build) (64-bit)

Any help would be greatly appreciated because I really don’t want to go back to Firefox or Chrome.

@Blazey Thanks for reaching out! I have Windows 10 x64, never seen this issue anytime. Is there any Antivirus sofware running in your machine and which might be causing this issue? can you check it again? revert back if issue did not resolve.

Thanks!

I do not have any anti-virus software other then the default windows defender.
Trying to re-create the secure connection problem, It doesn’t seem to happen when I open a fresh browser. I can open multiple websites and nothing happens. It seems to happen after the browser has been open for awhile and I play some sort of video formatted content.
Specifically I think it tends to happen after I have a video open on Youtube, or a stream. Afterwards, if I open any more tabs, I tend to get the secure connection bug. Opening a private window will still keep the bug, if it already happened in a normal window until Brave is closed and restarted.
However, when I try to replicate the bug in a private window instead of a normal window, it doesn’t seem to happen, which is confusing me as to why it is happening. Does it have something to do with blocking 3rd party trackers or cookies on a normal window? Or some other option? Because I tried disabling my extensions and that didn’t seem to be the problem…
What options get turned off in private window browsing that could be the cause of it in a normal window?

@Blazey Thanks for the detailed information. Can you please try the below options?

  1. If you have any extensions installed can you disable them and try again
  2. If you’re connected to any VPN can you disconnect the VPN and try again
  3. can you try disabling the global shield settings for HTTPS and open any YT video and check whether you are facing the same issue.

To disable global shield settings for HTTPS:

Let me know the outcome of above testing. Also, can you please check chrome browser and let us know whether the issue is reproducible or not?

Thanks!

Still no luck. It may not be Youtube videos, i’m just trying to figure out what is wrong and I can’t seem to pin down the cause. All I know is it happens half the times when I open a new tab it seems.
The only extension I have is Ublock Origin but it still happens if I have it enabled or disabled.
I have a VPN but it is not on right now, and I double checked in the task manager.
I still get the problem if HTTPS upgrades are enabled or disabled.
I don’t really know anything about web browsers so I am just trying random things in the hopes that I can figure out why it is happening. I have messed with nearly all the settings by now to no effect.
Is there any 3rd party programs needed? Like do I need to download java? I downloaded Adobe flash, but that wouldn’t cause the problem I am having, would it? And it couldn’t be my firewall if web pages still load, but they just stop when I open new tabs. So I am lost at what would cause it.

This topic was automatically closed after 30 days. New replies are no longer allowed.