Brave lags, takes 30-60 seconds to load pages

**Description of the issue:
Brave has become almost unusably slow, taking 30 seconds to load certain websites. I have uploaded a video, below, that shows the situation and compares brave, brave beta and chrome and also confirms my internet is not the problem.

**Steps to Reproduce (add as many as necessary):
reinstalled, deleted cookies, disabled extensions, installed beta version (same issue)

Actual Result (gifs and screenshots are welcome!):
Here’s a video showing the problem: https://youtu.be/qsGLxeoWbzQ

**Expected result:

Reproduces how often:
every time
Operating System and Brave Version(See the About Brave page in the main menu):
Windows 11 Home, 8GB Ram, 64 bit OS
Brave: Version 1.36.109 Chromium: 99.0.4844.51 (Official Build) (64-bit)

Additional Information:

@benschifman ,

Maybe:

FPS - Frames per Second known to be a contributing factor with “laggy” Brave Browser performance:

Another possible contributing factor – ANGLE graphics backend

Also, there is a Vulkan setting in some [Device Manager] video driver software, and testing that switch, has helped resolve some “Brave Browser laggy” issues.

UPDATE Monday, 20220307

@flasher777 ,

With release of Brave Browser v.1.36.111 (Chrome 99.0.4844.51) – re Chrome release notes contained Security Fixes for ANGLE:

[$10000][1289383] High CVE-2022-0789: Heap buffer overflow in ANGLE. Reported by SeongHwan Park (SeHwa) on 2022-01-21

[$7000][1285885] High CVE-2022-0792: Out of bounds read in ANGLE. Reported by Jaehun Jeong(@n3sk) of Theori on 2022-01-11

Ref.: “https://chromereleases.googleblog.com/search/label/Stable%20updates+Desktop%20Update

Thanks for brainstorming but I don’t think this is my issue. It isn’t video that’s a problem since just loading google.com takes about 30 seconds.

I turned off hardware acceleration in settings and that solved the problem

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.