[Resolved] My Brave browser is extremely slow now

Hey guys, I have been using Brave well over 2 years and I really find Brave to be an amazing browser with security and safety in mind. However, a few months back, my Brave browser started to lag consistently. Frame rate dropped exponentially and increased over the days I continued to use Brave. The last straw was when the Browser became too slow for me to use it for my school. I have been using Chrome for the past couple of months and I decided to finally use Brave again.

Brave was still:

  1. Slow
  2. Laggy
    3: Having FPS drops
    4: Screen buffering

I joined the Brave support community after trying to fix Brave.

I looked at previous posts on the forum and I tried the different ways to fixing my browser: Enabling Secure DNS (I couldnā€™t do it because of ā€œParental Controlsā€ couldnā€™t find a way to remove ā€œParental Controlsā€ and I donā€™t have ā€œParental Controlsā€), Update Brave (I am on the latest version), disabling Hardware acceleration (nothing happened), and removed Brave ads (nothing happened).

Can someone please help me fix my browser?

Edit: I am on Windows 10 (again, latest version) comment additional things I can mention to possibly narrow down the solution.

1 Like

Hello

It seems to me that Brave behaves randomly. It could work very fine with a device and not work fine with another one with the same settings. This beavior is reported before and can be found in the search. But this problem needs to be looked further.

Concerning the problem of harcware acceleration, you should restart your browser after setting ā€˜use hardware acceleration when availableā€™ to OF. If it doesnt work, then set your graphics card, like Nvidia for instance, to AUTO-Select.

Secure DNS works fine with me. May be the the problem couls be found in the windows settings, parental control??.

-I have windows 11 and latest Brave-

1 Like

Disable the extensions, and also try clearing the cache in brave://settings/clearBrowserData then restart the browser @Zeppelin855

1 Like

Thank you so much @fanboynz! That seemed to do the trick.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.