Brave is flickering when hardware acceleration is active

Description of the issue: Brave flickers sporadically when viewing any website

How can this issue be reproduced?

  1. Use an Nvidia RTX GPU
  2. Use Brave with hardware acceleration turned on

Expected result:
No flickering.

Brave Version( check About Brave):
1.29.79

Additional Information:
This is affecting my ability to view 3D files on Sketchfab, and I currently have to switch to another browser when doing so.

There was a prior thread about this issue that is now closed: Brave flickering while hardware acceleration is turned on

GPU: Nvidia RTX 3090
Driver: 471.68

CPU: Intel i9-10900
OS: Windows 10 Pro version 10.0.19043

2 Likes

Same problem. Alienware m15 R3, 2080 Super. Brave randomly (quickly) flickers black when hardware acceleration is enabled. Seen several topics about this since June which have all been auto-closed.

2 Likes

Also on Trisquel on an X200, possibly with “Mesa DRI Mobile Intel® GM45 Express Chipset (0x2a42)”, or tell me how to make linux tell me.

xscope logs without and with --disable-gpu:

brave-03-default.txt (970.6 KB)
brave-04-disable.txt (1008.0 KB)

Edit: this also suppresses flicker on Trisquel:

Edit: it no longer flickers on Trisquel 9.

1 Like

Could you check brave://gpu and see if, whenever it flickers, or if it flickered at all, the bottom of the page reports that the GPU Process crashed? I’ve been having this issue as well, beyond the GPU Process crashing and resulting in hardware acceleration being disabled.

I just reenabled hardware acceleration and reproduced the flickering. This was the message at the bottom of brave://gpu

GpuProcessHost: The info collection GPU process exited normally. Everything is okay.

I’m still having the flickering problem and it’s preventing me from using Brave as my daily-driver browser :confused:

I am seeing warnings for these problems. I’d post the whole log but I can’t attach files as a new community member…

Problems Detected

  • Some drivers are unable to reset the D3D device in the GPU process sandbox
    Applied Workarounds: exit_on_context_lost
  • Clear uniforms before first program use on all platforms: 124764, 349137
    Applied Workarounds: clear_uniforms_before_first_program_use
  • Disable KHR_blend_equation_advanced until cc shaders are updated: 661715
    Applied Workarounds: disable(GL_KHR_blend_equation_advanced), disable(GL_KHR_blend_equation_advanced_coherent)
  • Decode and Encode before generateMipmap for srgb format textures on Windows: 634519
    Applied Workarounds: decode_encode_srgb_for_generatemipmap
  • Delayed copy NV12 displays incorrect colors on NVIDIA drivers.: [728670]
    Applied Workarounds: disable_delayed_copy_nv12
  • Expose WebGL’s disjoint_timer_query extensions on platforms with site isolation: [808744], [870491]
    Applied Workarounds: enable_webgl_timer_query_extensions

I found a solution in my case, thanks to a Reddit user u/X0Reactor

Disabling VSync in my GPU settings resolved the flickering. Here’s the process for Nvidia GPUs:

  • Nvidia Control Panel > Manage 3D settings > Program Settings > Select Brave.exe > Vertical sync: Off

Hope this helps others with the same issue.

5 Likes

:clap: good news! thanks for advance :money_mouth_face:

Same problem. 5800H+RTX1650(i don’t know which gpu is working)
Turning off hardware acceleration can fix it.
Before updating to the latest version i had never had this problem.

If you’re still having the flickering problem see my fix above

updating:turning off RTX1650 and only using 5800H can fix it.(reinstalling Graphics driver didn’t work.)
Turning off hardware acceleration can’t either fix it.

I can confirm that this worked for me as well.

(Using an RTX 3080 w/ GSYNC monitor.)

EDIT: I replied to the wrong post, haha. My fix was using the NVIDIA panel to disable V-SYNC as suggested later in the thread.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.