Screen Flickering when Hardware Acceleration is turned ON

Been using Brave in my new laptop for last 2 weeks , whenever hardware acceleration is turned on the , the screen flickers , Turning of Hardware Acceleration is not a viable option for me , this did not happen with my old laptop

My specs
Intel Core I5- 9300h
GeForce 1650ti
8 gb ram
512 SSD
Laptop is Acer Aspire 7

Can you switch between from Intel to Geforce graphics, Intel graphics can be a bit buggy. So forcing GeForce 1650ti for Brave (via Windows Settings, Graphics Settings) @Aayush1105

I did, then when I opened brave- weird stuff started to happen , brave started getting pixelated and become white , everything looked weird…so sorry I dont have photo

Hello… I forced brave to work with Intel integerated graphics since nvidia gpu cause flickering for videos…any way thx

Hey @Aayush1105 ! Welcome to the community :smiley:

Do you happen to have any extensions installed? If so, can you try disabling them?

Porridge

I tried disabling all of the extensions… still the flickering didn’t stop, I tried to turn off Hardware Acceleration but then CPU usage reached 100%, still the videos lagged. After doing all this I found a solution - Turn on High Performance mode in pc , if option is not there then select ‘Create a power plan’- choose high performance in that , Since my Nvidia gpu cause stuff to flicker and once the whole thing started to became pixelated and become white - I went to graphics settings and selected my brave to run with integrated GPU…That fixed it for me…hopefully its helpful for others

1 Like