Splash page flickers unless --disable-gpu

Description of the issue:

When I start Brave with no restored tabs, I get a tab with a graphic, some statics and a time. In the default configuration, it flickers and tears, and future pages continue to flicker and tear.
When I start it with the --disable-gpu command-line option, it seems to load cleanly and stop spinning.
I view this as a continuation of:

and the advice came from here:

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Start Brave.
  2. Close all tabs.
  3. Start xscope.
  4. Start Brave with DISPLAY= pointing to xscope.
  5. Watch flickering.
  6. Quit brave.
  7. Kill xscope; eg ^c q ^m
  8. Start xscope
  9. Start brave with --disable-gpu
  10. Watch non-flickering.
  11. Move mouse over brave window; observe continued non-flickering.
  12. Quit brave.
  13. Fill xscope as 7. above.

Actual Result (gifs and screenshots are welcome!):
I will attach xscope output if I can work out how.

Expected result:
Accelerated and non-accelerated output are both clean.

Reproduces how often:
Always.

Brave Version(about:brave):
Version 1.29.79 Chromium: 93.0.4577.63 (Official Build) (64-bit)

OS Version
$ uname -a
Linux user-ThinkPad-X200 4.4.0-197-lowlatency #229+8.0trisquel3 SMP PREEMPT Tue Dec 1 13:00:01 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Reproducible on current live release (yes/no):
yes (or at least, the one that Software Updater gave me today)

Additional Information:
xscope output if I can attach it.

No longer flickers with Trisquel 9.