[SOLVED] Brave Browser window flickering

Sometimes my whole Brave Window starts to flicker. It appears especially when I watch youtube videos.
Yes, I have turned Use hardware acceleration when available off and I have also disabled Vertical Sync in my Nvidia Control Panel for Brave. But the flickering is still there and it is very annoying. I also feel like it has become more over the last few weeks.

I have read many forum posts about it but everybody seams to solve this issue with turning off Hardware acceleration. Unfortunately it doesn’t work for me.

Brave Version( check About Brave): v 1.62.153

Edit 31.05.2024: Today a similar issue happened to me again but in discord. I want to include my experience here because I think it might help others, although I’m not 100% sure it is the same issue: I experienced a similar flashing of the screen in discord. ofc I tried all that Nvida control Panel stuff but It didn’t work. I noticed that It’s not happening on a other monitor. I checked and as soon as I set my main monitor to 60 Hz and not 144 Hz the flickering stops. Long story short: I ended up using a more expenisive HMDI Cable and set my monitor to 120Hz and the flickering stoped.
I will probably invest in a more expensive DP-Cable soon so I can use my monitor with 144Hz again.
I hope this helps someone.

4 Likes

Uninstall GPU drivers, Clean install of Latest GPU drivers, Restart the PC, keep all Nvidia settings in default and see if the issue still exists or gets fixed

Turn on Hardware Acceleration after Reinstall/Restart

I uninstalled my Graphics card drivers via the Control Panel, installed new ones from the official Nvidia website and made a clean install. I rebooted my system turned hardware acceleration on and rebooted again.
I feel like the flickering got less but it is definitely still there.
I also restored the Default settings in Nvidia Control Panel.

Also tried checking in new browser profile ?

Yes on other Profiles still the same. However I think it doesn’t flicker when I have a Light theme in the Brave settings. Which I don’t want to keep though.

Then try installing the Black theme for Brave “Into the Black Hole”

https://chrome.google.com/webstore/detail/into-the-black-hole-true/faeadnfmdfamenfhaipofoffijhlnkif

Things got even weirder. So I turned back to dark mode but installed a theme (https://chromewebstore.google.com/detail/ultra-violet/lcknjpenlfdlffeafcadkbjfodmmgdip?hl=en) which in the end only changes the section with the Bookmarks, Tabs, etc.
But the flickering seams to be gone…

Thank you for your help so far
I think I will stick with the theme and see if it works

Also Make sure to try the above theme “Into the Black Hole” , Maybe it will work and fix and you will have Black Colors.

1 Like

I’ve had this come up a few times on fresh installs of windows and gpu drivers as well. One tip I would say is to try forcing vulkan within the brave:// flags settings. You shouldn’t need to add or change themes that’s kind of weird.

1 Like

Confirmed here. That’s definitely a regression that shipped as part v1.62.153 or previous v1.62.0x version.

I am with an intel CPU with no external graphics and didn’t have flickering occur on v1.61.

It flickers when a combination of the following occurs:

  • I am in my window-manager’s (i3wm) full-screen mode, or even actual full-screen mode (triggered with F11, only page content visible)
  • I do an action that triggers a popup menu. Now it doesn’t flicker with any kind of popup menu, but the kind that is actually centered horizontally. For example :
    • when adding a bookmark the first popup aligned with the start of the URL bar doesn’t flicker, but when editing the destination folder via ‘Choose another folder’ in the dropdown menu, it changes to another kind of popup and the whole window starts to flicker.
    • when I want to close a window with multiple tabs open and a confirmation popup appears.

This flickering is strong enough to make me feel like on the verge of having an epilepsy crisis. Clearly not something any user would want to live with.

Please let me know if there’s a better place to report this additional description of the bug. Definitely something off here.

OS: Linux
Window manager: i3wm
Brave version: v1.62.156
Graphics: intel integrated graphics
Screen resolution: QHD (non-curved)

Hey @JesusOfCarrots could you take a glance at my answer and let me know if your issue relates to what I described?

You marked your post as Solved, is it solved by the hack of changing the theme or something else?

Edit: re-read your post and saw you’re on windows and experiencing flickers mostly when using Youtube. As our issues might difer, I created another thread here: Whole window Flickering in full-screen mode with popups

I also find it quite weird. But it has been working since.

The flickering I experienced was mostly on youtube Videos or when I hovered over the adress bar.
Your description about you flickering seams different than what I experienced.
I hope you will find a Solution for your problem.
There are many of this community posts about it which seam to help for others. I can also advise you to look up this topic on reddit.

For the time your problem is not solved remember that you probably can export passwords, bookmarks and stuff like that to different Browser.

I had this problem, but in my case when hardware acceleration was disable it stops.

The root cause was the MFAA, setting it to OFF in the NVIDIA control panel solves the issue.

image

This is happening to me too. I have an Asus Viviobook s15. This sucks, seriously.

Same issue here but i only noticed it in youtube video, not an nvidia gpu but amd (rx 6950xt) flickering occured with and without hardware acceleration and i didn’t seem to have this issue before december/january could not pin point the start of it.
I am already using a black theme ( don’t think i could use oled one, too dark imo but i might tried)
after a few test i can say for sure that i don’t have that on Edge so really specific to Brave

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.