Brave is closed but I can't quit it and I can't reopen it. I'm using macOS Mojave

Description of the issue:
Brave is closed but I can’t quit it and I can’t reopen it. I’m using macOS Mojave
Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. I opened Brave as usual
  2. Tried quickly to open a page but Brave became unresponsive
  3. I quit the app using Command-q
  4. The Brave window closed but the app didn’t quit
  5. I tried to Force Quit it but it didn’t quit
  6. I opened Activity Monitor but couldn’t find the app there . It only appeared under Energy but grayed out
  7. I tried to uninstall it but it gave me a message that Brave is still open
    Actual Result (gifs and screenshots are welcome!):
    The message when trying to uninstall

This is the logo after quitting

The Activity Monitor Energy Tab

Expected result:

Reproduces how often:
The unresponsiveness happens a lot lately especially if I tried to open a new page immediately after the app just opened
Operating System and Brave Version(See the About Brave page in the main menu):
macOS Mojave
Brave Version
Additional Information:

This topic was automatically closed after 30 days. New replies are no longer allowed.