Brave not working on mac after quitting

Description of the issue:
Brave browser is not responding after quitting by mistake. I pressed cmd + q, tried to reopen the browser and it’s showing blank pages. I’m attaching some screenshots for reference.

I can’t event open the brave version

Attaching a screenshot of Brave task manager for reference

How can this issue be reproduced?

  1. Open brave
  2. Open good number of windows and tabs. In my case 7 Windows and 22 Tabs (Please don’t judge me by the tab count :see_no_evil: )
  3. Quit brave using Cmd + Q shortcut.
  4. Reopen Brave using Spotlight search in Mac

Expected result:
The brave should open and load all the windows and tabs which were active before quitting.

Brave Version( check About Brave):
Can’t check because brave not opening version or help or settings.

Additional Information: -


Try . . .

In a Brave Browser > New Window, go to: brave://settings/getStarted

  • Select: Open a specific page or set of pages
  • Select: Add a new page
  • Enter: about:blank (notice the colon)

Go to: brave://settings/clearBrowserData

For tab Basic - set:

  • Time range:All time
  • Enable: Browsing history
  • Enable: Cookies and other site data (Signs you out of most sites)
  • Enable: Cached images and files

Click on the “Clear data” button.

(The “Clear data” button also saves the selections.)

Go to: brave://settings/shields

  • Disable: Auto-redirect AMP pages

If you have an older version of Brave Browser, try:

  • Disable Enable De-AMP at brave://flags

Go to: brave://settings/content

Scroll down to “Additional permissions” . . . and set:

  • Protocol handlers: Don't allow sites to handle protocols
  • File editing: Don't allow sites to edit files or folders on your device
  • Clipboard: Don't allow sites to see text or images on your clipboard
  • Window placement: Don't allow sites use info about your screens to open and place windows

Scroll down to “Content” . . . and set:

  • Pop-ups and redirects: Don't allow sites to send pop-ups or use redirects

1 Like

Hello @289wk ,
Thanks for the response. I tried to open all the page you mentioned, but none of them are getting open

Hope I can get any other solution :slight_smile:

Deleting the BraveBrowser app from Applications directory and downloading again worked. Gladly all the bookmarks and plugins are there. Thanks for the support anyway


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.