Brave interface stuck to my OS regional settings language


Description of the issue:
I am trying to change the language of the Brave interface to something different from my OS regional settings language.
Whatever language I put at the top of the list in “Settings --> Additional Settings --> Language”, nothing changes. I need to put the language I want at the top, right?

How can this issue be reproduced?
See above

Expected result:
Have the Brave interface be in the language I selected.

Brave Version( check About Brave):
0.69.135 Chromium: 77.0.3865.120(Official Build)

Additional Information:
OS: MacOS Mojave

1 Like

@erikku no. You need to click three dots menu next to language you choose > Show Brave in this language.

EDIT:

Thanks for your reply @eljuno.
The thing is, I do not have the “Show Brave in this language” when I click on the three dots.
The only options I have are (translated to English):

  • This language will be used to translate the page
  • Move down
  • Delete

Same for me!
This option doesn’t show up for me either.

Thanks for the confirmation @rodrigobb @erikku.
cc @Mattches @sriram @steeven for additional testing since I’m not use macOS.

Sorry for not giving details, I’m not on Mac:

OS: Linux Mint 19.1
Brave Version: same!

1 Like

@erikku @rodrigobb,
When you go to Settings --> Additional --> Languages, you should seen something that looks like the following after clicking on the drop down arrow to the right:

To add another language, select Add languages.
If you’d like websites to offer to translate a page for you that isn’t in your default language (that is, the one at the top of the list), ensure that this option is toggled “on”.

Does this help the issue you’re facing?

@Mattches,

What you say is fine, what we mean is that the browser interface is in English. See bellow:

Language Printscreen

Everything is in english, “Language”, “Other languages…”, the whole browser.
We are trying to set the Browser language, not the typing language.
@eljuno suggested that the context menu should actually show like that:

When you click the three little dots, which options are displayed to you?

@rodrigobb,
Thanks for clarifying.
Windows allows far more liberties – with respect to the platform itself – than macOS does. Windows offers the option in-browser to display the UI in [language]. However, on macOS, you have to custom set the language on a per-app basis. Try the following:

  1. On your mac, navigate to System Preferences --> Language & Region
  2. Select the Apps tab.
  3. Click the + symbol to add an app to the list.
  4. Select Brave, and the language you’d like to view the browser in.

Enjoy :slight_smile:

2 Likes

@mattches I believe @rodrigobb is on Linux Mint. Would it still work the same as Mac?

1 Like

Hello!

Indeed I’m in Linux Mint and things are different here. I can’t set the language of individual softwares, the Mac concept of “App” and its management doesn’t exist.

Anyway, it seems any chromium-based browser behave like that on Unix (max/linux). In Google Chrome and Chromium I can’t set the language either!

Only in Firefox I have this:

Which, after setting to portuguese, it does work:

I think you can close this thread, it seems it’s a chromium-issue and OS limitation, dunno if you can or even should do something about it.

1 Like

@merlaux thanks for pointing that out!
@rodrigobb – I believe you’ll have to change the device language in your system prefs in order to get the browser UI to display in the appropriate language.

Hi @Mattches, I think that this behaviour doesn’t make sense.

If I select a language, the browser UI should be changed (independently of the language installed on my computer).

For example, I have installed Spanish on my computer Mac and it is impossible to have Brave in English. :S

@Franky_FFV,

That’s actually not the case! On your mac if you go to System Preferences --> Language and Region --> Apps, you can add apps with custom language settings different from the default one assigned to your OS to this list.

This option only is available in Catalina because in Mojave doesn’t show Apps tab.

@Franky_FFV,
Interesting! I actually wasn’t aware of that. Thank you for letting me know – I’ll have to get some documentation written on this.

This topic was automatically closed after 30 days. New replies are no longer allowed.