Cannot change UI language on Linux Ubuntu

Hi!

Brave cannot be displayed in any other language than the system’s default. For example if I use Ubuntu in Russian, I cannot change Brave’s language to English, there is no option for that when I click on the three dots symbol right to the English in Brave’s language settings. I’ve encountered another thread with a similar problem, but there were no solution for this problem: Brave interface stuck to my OS regional settings language

Brave Version: 1.16.76

Unfortunately, I don’t believe there’s an easy setting for this.

As a work-around, if you start it from the command line, you specify the language like this:

LANGUAGE=en brave-browser
2 Likes

Thank you! I’ve successfully created a bash script for this and a .desktop shortcut in order to run it smoothly from a dock bar. Required some digging, but works correctly at the moment. Is there, by any chance, an ETA for language changing feature to come up on Linux? Maybe next updates?

1 Like