Set the browser language

Despite the tutorials I can’t put Brave in English.
By default it is in French.
I am in France and my Macbook is in French, but I would like to have Brave in English or to be able to change the language when I need it.
In the tutorials it is shown that you have to check the box “set up Brave in this language” but this box is not there for me. Thanks for your help.


which version are you using?

Maybe this helps:

1 Like

Hi and thank you for your reply.
I did it already, but there is a missing point.
My Macbook Air is setted up in French.
But I’d like to be free to modify Brave if needed.
I follow the right steps but at the end, I cannot modify the Brave browser settings. Only the additional languages or translate.
When I use Brave, I’d like to see it in English (or French, or Italian, etc if needed)
My Brave version and my Mac are updated.
Version 1.44.105 Chromium: 106.0.5249.91 (Build officiel) (x86_64)
Capture d’écran 2022-10-04 à 19.01.41

Apparently this is an issue that happens with linux and mac.

I’ve found the following solution, hope it helps:

Otherwise, as far as I know, the only way to solve this is to change your OS language.

Is there any other way to change the browser language @Mattches ? Thank you!


@pcg thank you for tagging me. @tototata — please let me know if the proposed solution above works for you. If not I’m happy to help troubleshoot further.


It worked.
I did not know it was possible to change the language by app on MacOs.
Great support and help.
Thank you very much !


You’re very welcome and thank you to @pcg for jumping in as well.