Brave does not connect to any URL after a Windows restart

windows
#1

I installed Brave yesterday on my windows computer. It ran fine. I restarted the computer this morning. When I opened Brave it said the two extensions I had installed crashed. When I tried to go to a website, any website, it doesn’t get there. It doesn’t give me an error message. It just spins for a minute then the page is all white and the tab says Untitled and the icon on the tab looks like a black folder with a frowny face.

I uninstalled the extensions and restarted the computer. Same results. It won’t connect to any sites. White page and black folder frowny face on the tab.

I uninstalled Brave and reinstalled Brave. Did not install extensions. It worked fine. Connected to every URL I entered.

Restarted my computer. Opened Brave and again, it can’t connect to any site. White page and black folder frowny face on the tab.

Anyone have any idea what is going on? Is there an error log sitting someplace that might give me a clue? I don’t see anything in the event viewer. I’m not having any problems with any other programs at the moment.

Windows 10 pro version 1809 build 17763.316

I’m not sure what version of Brave I have. It’s whatever would have been installed today, 03.07.2019. I tried going to the About page to see the version but I just get brave://help in the address bar, it spins for a minute and I get white page and black folder frowny face in the tab.

So there is another thing. Not all of the menu options work. New tab worked. History doesn’t. Settings doesn’t. More Tools -> extensions doesn’t. The menu options that don’t work just give me white page and black folder frowny face.

1 Like

#2

@terrydiederich,
Thanks for reaching out to us! Great report btw, appreciate the effort and detail you put in.

This sounds like a Hardware Acceleration issue but it’s weird that it produced after working properly. Since you’re unable to view Settings in-browser, you’ll have to try and launch Brave with the --disable-gpu flag to test and rule this out. Quoting myself from separate thread:

  1. Find the shortcut for Brave (generally on Desktop), right-click and select Properties from the context menu.

  2. Click into the “Target” field, and type --disable-gpu at the end of the path. Note that you must type this outside of the quotes with a space between the flag and quotes . It should look something like this:

  3. Click Apply then OK then open the modified shortcut you just created.

Alternatively, you can try launching Brave from the terminal as well using the same method. Terminal command would be start brave --disable-gpu
Try this method and let me know if this works for you.

1 Like

#3

Hi Mattches,

Thanks for the response!

Unfortunately that did not change anything. I tried both ways to test it just to be sure, changing the shortcut and running Brave from the terminal. Nothing changed.

Also, I uninstalled and reinstalled and everything worked again. I found the hardware acceleration setting in the settings section and turned it off. Then I restarted my computer and Brave stopped working again. So it appears hardware acceleration is not the issue?

It does seems strange that everything works great when I install it and then stops working when I restart the computer. I ran Brave for about 6 hours yesterday and everything worked great.

Anything else I can check?

2 Likes

#4

Very puzzling.
Let me reach out to a few team members about this, thank you for your patience.

1 Like

#5

Also, just to confirm, is there any output from the Console screen in Dev Tools when you try to visit a site?

Also also, which extensions did you have installed when this error was first encountered?

1 Like

#6

I assume you are asking about the More Tools -> Developer Tools menu option? If I select that nothing happens. I assume if everything was working a console window would pop up someplace but nothing happens when I select that menu option so I don’t see the console window. Let me know if you are referring to something else.

The two extensions I installed at first were:
1Password

Send from Gmail (by Google)

I don’t have any extensions installed now.

1 Like

#7

Thanks for the info. Next question, did you ever have or use Brave on a connection run though a VPN service (or is it running through one now)?

This is what I was referring to but I forgot that you were unable to view the window. You might try opening it via keyboard shortut - ctrl + shift + I for Windows I believe.

Another possibility: When you uninstalled Brave (any time) did you elect to remove profile/browsing data as well? It should have appeared in a system prompt with a check box. If you did, ignore the following.

If not, it could be the case there is is “bad” profile data still on your system that Brave is still picking up because the profile install path/files (that may be corrupted) are still present on your machine and just keep getting re-read. You can also delete it manually after uninstalling (if you miss the prompt or it doesn’t show for some reason) by navigating to ~/users/[username]/AppData/Local/ on your machine and deleting the BraveSoftware directory. Note that your browsing data will be lost when this is done.

I personally encountered this not too long ago myself after an update. I was unable to access certain websites or features of certain websites and I was 100% sure we’d broken the browser. However, creating a new profile resolved the issue for me, as Brave was pointed at new/different data.

Let me know what you find out.

1 Like

#8

No. I have never used Brave through a VPN service.

1 Like

#9

More strangeness. When I started my computer this morning I started Brave, not expecting it to work. However, for some reason it did. Not sure why. But I closed it and restarted it and now it doesn’t work again. I’ve shut my computer down and restarted a couple times but Brave has not worked again. Not sure what happened that first time!

I tried ctrl + shift + I and it does not bring up a window.

I uninstalled Brave and checked the box to remove the browsing data. Then I went to AppData/Local/BraveSoftware and found that it was an empty folder except for a CrashReports folder that was also empty. I deleted both of those just to be sure everything was cleared out. I reinstalled Brave from the website. It worked, as it does every time after the initial install. I restarted my computer and it is not working again.

2 Likes

#10

@terrydiederich,
Thank you for the information and for the rigorous testing on your end. This is quite the puzzler - I don’t know why it would work and then cease to work on reboot.

Next test:
Try downloading our Beta and/or Dev builds (these can be downloaded, installed, and run at the same time) and installing. Reboot your machine and see if either of the other builds produce the same issue.

1 Like

#11

Same results for both the beta and dev builds. Everything works fine right after the install. Then I restart the computer and they can’t connect to any url. Some options don’t work, like Settings.

It looks like it’s just not meant to be on this computer.

2 Likes

#12

FWIW, main Brave Version 0.60.48 Chromium: 72.0.3626.121 (Official Build) (64-bit) in Windows 10 Home Version 10.0.17763 Build 17763.

I did notice that there is an entry for Brave in Windows Defender Firewall to allow Brave to communicate through the firewall, and in mine both Public and Private profiles allow this. That might explain why @terrydiederich can’t reach external sites if one or both profiles don’t allow Brave through the firewall, but would that interfere with settings pages?

1 Like

#13

@terrydiederich,
Still looking into this.
@hnktong brings up a good point - do you have any AV running in the background or that runs at machine startup?

2 Likes

#14

We are running Webroot SecureAnywhere. This is a work computer and I know very little about Webroot.

1 Like

#15

Looks like it has a firewall as well as AV and a bunch of other stuff. Here’s a link to the User Guide for the Home version. If Home has it, I’m guessing Business does, too.

To this amateur (me), that doesn’t necessarily mean it’s blocking Brave, but it’s suggestive that it doesn’t recognize Brave as an allowed application.

1 Like

#16

I don’t have access to make changes to Webroot to try anything. Unless @Mattches has any other suggestions, I’ll assume we’ve reached the end of the line for now.

2 Likes

#17

@terrydiederich,
Sorry for the delay and thank you for bumping this thread. Let me ping some people about this again and see if anyone knows whats up.

In the mean time, we’ve released v0.61.51 as of yesterday, have you updated to this version?

1 Like

#18

Just tried v0.61.51. No changes. Works fine when I first install. Stops working after I restart.

1 Like

#19

@terrydiederich,
Do you have any AV or registry cleaners running in the background or that trigger on shutdown/restart?

1 Like

#20

No registry cleaners. As I said Webroot Secureanywhere is the AV. It runs on restart.

1 Like