Brave desktop browser don't show any ads

Hi,

I hope somebody can help me, my brave browser is not showing any ads on my desktop PC. On my mobile device I also have brave installed and there i get the ads and rewards like intended.

Settings:

-Brave ads and rewards are enabled (5 ads / hours)
-Region is Germany
-Brave is the standard browser

I did read the FAQ and some forum postings, on some posting it’s suggested to check the windows notification settings, I did everything set up like in the posts.
But one strange thing is that brave don’t show up in the notification settings in the windows settings.

I tried to install the brave beta, brave nightly and latest brave build. But none give me any ads or rewards.

Somebody got an idea what is wrong here? :frowning:

See screenshots for Windows settings:


1 Like

you been using it for a matter of days and still no ads? Sometimes I don’t get any for like an entire day…I guess because there just aren’t enough advertisers yet, i dunno. But if you’re never seeing them at all, then sounds like there’s a problem and i don’t have any answers

@Nickhawk,
To confirm, if you go to Settings --> Notifications and actions – then scroll down past where it says Get notifications from these senders Brave does not appear here?

1 Like

@Mattches yes like you can see on my screenshot, there is no brave browser on the notifications & actions page, only chrome is there even if i set brave to the standard browser. Installed with admin rights etc. nothing helps :frowning:

@Nickhawk my apologies – I didn’t see the entirety of the image you shared above.
This is certainly strange – can you confirm for me what Brave version you’re using?

no problem :slight_smile:

thats my brave version:

like i said i also testet the beta version and the nightly´s with the same result (none of them appear in the notification settings).

Hi @Nickhawk sorry for the inconvenience here, can you go to brave://rewards and look for the link for 7 day ad history at the bottom of the ad panel (not sure of the translation but mine looks like this)

and paste in what you see?

@jsecretan here is a screenshot… zero ads… on my mobile i did get in the same time 27 ads. Mobile brave and desktop brave are installed at the same day.

Hi @Nickhawk I’m going to try to DM you a restore key that might work.

Hi,

i used the restore key, but sadly it didnt changed anything. Brave is still not showing up in the notification settings and i dont get any ads. :frowning:

1 Like

Hello, I have also been getting this issue for over a month now and i’m in the same situation as this guy. I’ve read everything to do with how to fix it from various threads and solutions/FAQ and none of them have worked.
However, I have found a possible solution I stumbled upon on my own, and that IMMEDIATELY gave me one ad. (I never thought i’d be so thrilled and excited to see an Ad LMAO)

When I logged out of Windows (Pressing “Windows + L” keys), then relog a few seconds after; an Ad pops up in my notifications tab on the bottom right corner.
I could repeat this about 3 times within an hour, with about 15mins between each relog, until it no longer functions. (The default ads setting is on the potential “5 ads per hour”).

At one point about 2~3weeks ago I could no longer reliably reproduce this. Only every now and then. Like once every 2~3 days or something very low.

When I relog, the ads show perfectly. It pops up with a sound.
Any idea what this could be?

1 Like

As already mentioned, I’m having the same issue. The solution that @JetSetz mentioned also worked for me but only a few times. After that it never worked again.

@Mattches Perhaps my above solution could be of use. I tried it on my uncle’s PC who also was getting a similar issue and it resulted the same way. It’s a temporary way around things but needs fixing.

1 Like

Why does not Brave say anything about this issue? At least they could reply to this topic and could provide us with new information about this problem. Why should I use a browser like Brave, when Brave Rewards is not working probably? Please fix this problem asap.

Same here as mentioned here: No ADS with brave
Login/logout doesn’t work. Changing region/language/VPN doesn’t help as well (sometimes it brings an ad, then that’s it). I used to get much more ads than that. Quite annoying.

No answers… :thinking:

Brave doesn’t care about our problem. We still didn’t get any information about this issue and we won’t get it. That’s very sad. :frowning:

1 Like

@GreenLion @JetSetz,
Can you confirm for me whether or not you’re receiving no ads at all anymore, or just that you’re seeing fewer ads than you have been previously?

No ads.

@JetSetz,
There must be something set up incorrectly with your Windows focus assist/notifications settings. If you’ve been able to provoke/see ads then the system is working as intended. Can you double check and ensure everything is configured correctly?