Brave crashes every time I start it

Every time I open Brave browser it just refuses to open. I do not get any crash report, it just doesn’t open. It started doing like this last 2-3 weeks. I checked multiple solutions online. They seem to work at the beginning but maximum after one day the browser returns to its previous state.

Note: usually after waiting for some time (approximately 15-20 minutes) I am able to open it.

Solutions I tried to fix it which I found on community webpage:

1) I did deleted all files on Brave Browser, deleted application from storage, reinstalled Brave Browser. It worked fine for one day and then refused to open again.

2) I found a solution where ad blocker was causing issue. I have tried that too by changing text file “Local State”. Worked after this and the day after back to not opening.

3) Found a solution where you delete files from brave browser. Next day the same again.

4) Yesterday found another solution where you type this - open -a “Brave” -n --args --profile-directory=“testprofile”, it seemed to work and I finally had solution. But today I am back to previous problem again.

Operating System: MacOS Sonoma 14.1

Brave Version: v1.59.124

Couple days ago I was using macOS Ventura and having the same issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.