Brave won't start since the newest update (macOS Sonoma Version 14.1)

Since I updated my Brave the last time it won’t start anymore but even before that I noticed that new tabs weren’t loading anymore and there was only this one loading icon. After closing the browser and trying to start it again it won’t open anymore. I click on the brave icon, then it tries to open for one second, freezes and then closes complete.

I tried to delete brave and reinstall it several times but the result is always the same

1 Like

Do you have an answer for me @Mattches ?

1 Like

Can you please test and try installing the Beta Build and tell me whether or not you get the same behavior there?

1 Like

I downloaded the beta build and it behaves normally now. I synced the beta version with my normal and have all my passwords and so on.

Will I now have to continue using the beta build?

1 Like

Latest update killed my Brave browser so where are they previous versions?

Let me just add that just steamrolling ahead and not considering that not all users are onboard with the incessant updates race for whatever reasons is not a winning strategy.

1 Like

The fact that the Beta works means that the issue is likely not specific to the browser but more likely something with your profile/browser data causing the crash. Have you updated to the latest build on stable (v1.60.114)?

You can find previous versions here:

1 Like

@Mattches Cheers, but no older versions here…

1 Like

You need to search for them.
You can also jump to a previous version directly by entering the appropriate version number in the URL, or by clicking the Tags button and finding the correct version that way.

For example, the version that was last released before the latest is v1.60.110. So the URL for that would be:

You can use the Release Notes page here on Community to find the exact version you’re looking for.

1 Like

I just deleted the normal version of Brave and dowloaded it again to have the latest update but there is still no change in the Problem that I described beforehand :frowning:

1 Like

Yup - they made a real mess of it… same old story with successful apps, they get ahead of themselves and voila! Total cockup followed by collapse. Anyway, good luck


Thank you, found one, but it wasn’t easy and there were glitches “somewhere”… seems to be working now so I’m happy…

1 Like

Can you please try opening the macOS Terminal and entering the following command and tell me if the browser opens with a new profile window?

open -a "Brave" -n --args --profile-directory="newprofiletest" 

If it does, can you please see if any crash reports appear in brave://crashes?

It opened again with a new profile and yes I have 49 crash reports. Probably from all the times I tried to open the browser. They start from 1st of November until 11th of November

Can you please ensure those reports are sent (if there is no option to send them then they already are) and please share with me the last five or so crash report IDs with me here so we can take a closer look?

Thank you


Can I now continue using my normal profile in the normal brave browser? Thank you in advance

Well since it is still crashing you cannot. But I’m hoping that the team can look at these crash reports and find the cause of the underlying issue so that you can use it again in the future.

Any updates on what was the issue and if I can use the normal brave browser with my normal profile again? I am still using the beta version where I haven’t encountered any problems yet

I’ve been using beta for the same reason for a while. But, this worked for me for the current stable version.

open -a "Brave" -n --args --profile-directory="newprofiletest" 

So this opens Brave with a New Profile. But if I closed it, and opened Brave again, it opens with the original profile, and crashes again.

The the problem seems to be with the bookmarks in my profile. So I opened Brave with command line, deleted the problematic profile, created a new profile and now it doesn’t crash.

Next I will port everything from the Beta to the Current stable version and report back. Hopefully it still works.

Update: I synced everything from Beta to the current stable version. Everything works fine.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.