Brave Browser crashing/closing after being opened for 10-30 seconds everytime


Description of the issue:
Brave browser keeps crashing every-time regardless of the website being opened

How can this issue be reproduced?

  1. Open Brave browser
  2. Wait 10-30 seconds
  3. Crashed/Closed without error message or any sort of notifications

Expected result:
Should be open

Brave Version( check About Brave):

[Version 1.11.97 Chromium: 84.0.4147.89 (Official Build) (64-bit)]
Windows 7 (64 bit)

Additional Information:

Before encountering this, I used the Task Manager and used the “End Process Tree” for Brave browser since it was not responding, Even after rebooting the problem still persists.

Picture below is the crashes. Even if clicked the “Send Now” button, brave browser would close before sending/uploading it.

@tween,
Can you keep the browser open long enough to try disabling Hardware Acceleration and see if that helps?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

Hi There Mattches, I have disabled the Hardware Acceleration just like you said, but brave browser is still closing after 10-30 seconds :slightly_frowning_face:

I am opting to re-install my brave browser but am concerned if my BAT/Brave rewards wouldn’t be saved after re-installing.

@tween,
Can you try re-running the installer (this will not overwrite anything, it will just fetch the update files) so the browser updates to the latest release (v1.11.101 at the time of writing this)?

Sorry late reply.
I have done what you’ve told me to do, but Brave browser still crashes, Im losing hope now :slightly_frowning_face:

@tween,
Do you know if you have enabled Brave Sync at any point via Brave://flags ??

I’m on Linux Mint, I’m crashing also. I ran it from the terminal and have the messages from running to before the crash. I tried to paste the whole thing but its too long. I tried to upload a txt file but it restricted me because I’m a new user. Here is the last part of the message.

Resolving cr.brave.com (cr.brave.com)… 199.232.5.7
Connecting to cr.brave.com (cr.brave.com)|199.232.5.7|:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 36
Saving to: ‘/dev/fd/4’

 0K 

Failed to get crash dump id.
Report Id: 092c0000-319a-ce
mackism@blakdeb:~$ /usr/bin/brave-browser: line 48: 273739 Segmentation fault (core dumped) “HERE/brave" "@”

should read first. i remember the notification about sync. I just turned mine off. I’ll see if its the issue.

1 Like

I’ve been using Brave as my primary browser and have been facing the exact same issue since I updated about two updates ago.
about 15-30 seconds is what I’d get before it would crash again. I’m currently on V1.11.104 with the same issue on a macbook air running MacOS Mojave 10.14.6

I tried updating but it would crash before I finished updating so I finally downloaded the latest update via firefox and reinstalled brave, but it was in vain.

I saw something about disabling the hardware acceleration and GPU flags that helped a couple of folks so I just tried that and I haven’t had a crash for about 15 minutes now but I’m monitoring the same.

I’ll keep you folks posted, hopefully this will help sort it.

I have turned off sync and I haven’t had a crash since. So I guess that was my problem.

3 Likes

Brave was crashing any time I tried to navigate from a new tab to any URL. I could occasionally open one site but only if it was the only tab open.

Disabling sync appears to have solved the issue for me as well. Thanks for the suggestion!

1 Like

Sorry for the late reply, As Mattches 1st mentioned & bigpoppaken mentioned,
I had turned off or disabled the “Enabled Brave Sync” in brave://flags/
I haven’t got a crash since changing this setting.

Thank you Guys for all your concerns/replies, and I would just tagged your reply @bigpoppaken as a solution to my problem.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.