Brave constantly running in the background

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Description of the issue:
Constantly running in the background on android 13 and use lots of battery

How can this issue be reproduced?

1.leave it open
2. Use it normally

Expected result: not running in the background

**Brave Version( check About Brave):**latest

Mobile Device details Android 13, Samsung S23 series

Additional Information:
If you force close the Brave browser, it’s okay as it won’t run in the background. However, if you just close it from the app drawer, it will still continue running. The same applies if you put it in the sleeping app - it will still run without any reason. Whether you have tabs open or not, it doesn’t make a difference.

Clearing the browser details and closing all the tabs on exit won’t change anything either. The browser will still consume around 20% of your battery on daily usage. There might be some settings that can help reduce battery usage, but it’s not clear which ones they are.

Thank you

@MrQuantum I could be wrong but I believe this is due to Brave Rewards and all. It would need to run and send you the ad notifications.

Well, if it’s anything like my Samsung S9 that’s running on Android 10, you just go to your Android’s SettingsDevice Care (otherwise just Battery) → BatteryApp Power Management and from there you can choose to put apps to sleep. On mine there’s sleeping apps where it puts to sleep when haven’t used for a while. Then there’s Deep Sleeping apps , where anything on this list will never run in the background and will only work when you open them.

That said, I’ll tag @Mattches on this in case there’s anything I’m not thinking of. I mean, I doubt you going to Settings on Brave and enabling Closing all tabs closes Brave would make a difference. And unlike Desktop version of Brave, there’s no battery saver mode flag to enable.

Thank you for your response. Even though I have put it in the sleeping apps, the Brave browser is still running in the background. I haven’t enabled any rewards, but I can’t find an option to put it into deep sleep mode. I have also tried turning on the restricted mode in the battery section, but it doesn’t seem to make any difference.

@MrQuantum Ok. So as a normal User, that’s about the end of my guessing overall. I did tag in the main person for Browser Support. Hopefully he’ll swing by here later with ideas. You would think with all of that done, it wouldn’t be running. Especially if you’re saying you fully closed the app and exited it from the app drawer.

Unfortunately, I switched from Android to iPhone, so I’m starting to lag behind on things you can do on Android.

Can you tell me how what you’re using to observe Brave run in the background even after closed?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.