Brave browser stopped working on ONE of my Mac computers

The app opens, but it is not connected to the internet. Other browsers work fine, but Brave refuses to work. I tried to uninstall it and re-download it but it didn’t help, same issue persists. Did a customer support screen share session with Apple, but they found nothing that could cause it and advised me to get in touch with Brave. I use Brave on 3 computers and one phone, all synced. It stopped working on my absolute most important computer so please help. Thanks!

Hi, @adrianwinther . Sorry to hear of your troubles. We need a bit more information to really help.

What version(s) of macOS are you using on the various machines? I have one machine running 10.14.6 and one running 12.3 and they can react pretty differently, though it sounds like you are probably aware of that.

What version(s) of Brave are you using/trying to use? For the one that won’t stay open, try selecting the application in the Application folders and do Cmd-i or pull File menu down to Get Info. I’m assuming it’s the most recent official release, but if it’s Beta, Dev, or Nightly, that’s important to know, too. For example, I’m using Brave 1.39.22 based on Chromium: 100.0.4896.60 (Official Build) nightly (x86_64) on the 10.14.6 machine (from the application’s version page brave://version), and Get Info looks like this:

I’m tagging @Mattches in case he wants logs or something to aid in diagnosis.

Thank you for helping me!

I’m running MacOS Montery, version 12.3.1.
The Brave Browser version:
Version 1.37.109 Chromium: 100.0.4896.60 (Official Build) (x86_64)

To clarify, the app does stay open, it does not close. (I read from some people having a different issue, where it actually closes.) Mine stays open just fine, but not connected to the internet.

Thank you,

OK, thank you, @adrianwinther. I’ll be on my 12.3 machine soon and will tinker, such as by creating a new user and installing your version of Brave and seeing what happens.

Do your other machines on which Brave works run the same versions of macOS and Brave? I ask because if they lag on macOS a little, maybe your issue arises from a change in permissions by Apple in a recent update.


I’m also curious if you have any extensions installed in the browser at this time? Additionally, how long have you had Brave installed? Did it only stop working after the update to v1.37.109?

1 Like

Well, that experiment wasn’t productive of a solution, though I can say it doesn’t appear to be bad Brave code or something obviously brought on by updating to 12.3.1.

If you feel a little adventurous, you could create a new user on your Mac and see if it has better luck or asks for something that would make sense as far as why your main account won’t let Brave work.

Here’s what I did/found:
I created a new user, installed Brave 1.37.109 Chromium: 100.0.4896.60 (Official Build) (x86_64) on 12.3 (not 12.3.1) and it worked fine, didn’t ask for anything.

Then I updated to 12.3.1 and there was no change in behavior.

So there goes that idea. I’m actually using that version of Brave to post this, albeit on my main account. When I launched Brave on my main, though, it did ask for something, though I doubt it would have an effect on connectivity. Here’s the dialog:
Screen Shot 2022-04-01 at 6.26.39 PM

@adrianwinther ,

On your Mac

Quit all your applications

Start Brave Browser

In a New Window, enter Brave URL:


Click on “Clear host cache”

Enter another Brave URL:


Click on “Close idle sockets” . . . and then click on “Flush socket pools”

Quit Brave Browser

Next, locate the “Caches” folder:


Therein, find and move the “BraveSoftware” folder (if any) to the Trash

And, find and move the “com.brave.Browser” folder to the Trash

Restart your Mac, and let it settle down

Start and test Brave Browser. Is your issue fixed?


Quit Brave Browser.

Start up your


In the Keychain application window, you should find the Brave Safe Storage login item - you may have to carefully read several items, to be sure:


If it exists, double-click on it. You should next see the Brave Safe Storage window > Attributes tab


Click on the Access Control tab. Result:


THAT setting, what you see, is what @hnktong set, when filling in the dialog window, and clicking on “Always Allow”:

IF you do NOT have the Brave Safe Storage login item in your main Keychains window, then quit the

The problem your Brave Browser has, may be a POSIX permissions issue that prevents the creation of the Brave Safe Storage login item . . . and possibly has been affecting some other files associated with Brave Browser functions/ops.

You do NOT have to do the following, but you might try it, after some research on your own. The following commands will not mess up your Mac. Your login keychains are within the “Keychains” folder, within your user account home directory’s “Library” folder.

The commands will remove the grip of

  • Immutable flags (clearing immutable bits)
  • ACL (Access Control List entries)

. . . on your user account home directory’s “Library” folder:




You can drag-copy that entire “Library” folder to an attached, external hard drive.

When prepared, and you wish to proceed . . .

Start up the (it is also in the Utilities folder).

This may be your first work in the Terminal window. You will do OK. You will be prompted for your user account password, when the Terminal window responds to the first, of the following commands…

One-at-a-time, enter these commands, substituting your actual user account username :

sudo chflags -R nouchg /Users/username/Library 2>/dev/null

sudo chmod -R -N /Users/username/Library 2>/dev/null

Quit the Quit all other applications.

Restart your Mac. When it settles down, start up Brave Browser.

You may be prompted with the aforementioned dialog window.

1 Like

Thank you guys very much for your inputs and troubleshoots!

This eventually solved the issue for me: Noticed in my mac system preferences - networks that my Nord VPN app was going haywire. I had already disabled it and tried to get my Brave to work with the VPN disabled (although I always use it with, but since I tried everything I naturally tried this too.) However, even though it was disabled and “off” it was doing some loony tune moves that I don’t have the tech knowledge to describe, but it was just bouncing up and down and being weird. So eventually I erased Nord Vpn completely and re-downloaded it, and now everything works fine.

Thank you!


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.