I can't launch Brave on macOS Catalina


Description of the issue:
How can this issue be reproduced?

  1. I installed brave on my Mactop with Catalina 13.0.2
  2. when I launch Brave version 78.0.70.121
  3. I have a pop-up saying that “Apple can’t check if there is no malware contact the developper”

Expected result:
Launching of Brave

Brave Version( check About Brave):
78.0.70.121

Additional Information:

4 Likes

There yo go


?

I have exactly the same!!!

@jakouiller,
Can you check and see if you can allow Brave permission to run on the system level by going to System Preferences --> Security on your mac and allowing it manually?

I tried this but it did not work.

@homer44,
Can you tell me what happened? Did the browser appear as blocked by your system? I can confirm that this worked for me, as I had to do it for each Brave build I have installed on my machine (so 4 times).

I had to delete the Brave browser because of an email issue. Then I upgraded my iMac OS Catalina to Version 10.15.1. I then downloaded Brave again. When I went to open it, the photo I attached above, appeared and will not let me proceed in any fashion to open up Brave.

I have the same issue. Reinstalled Brave after updating to MacOS Catalina and get

Can’t install, needs to be updated messages
2019-10-31_09-29-27

To repeat, this is a Catalina issue and can be solved by simply allowing the app to run in Security Settings, or by following these simple steps.

Thank you Mattches Solved!

Le jeu. 31 oct. 2019 à 17:35, Mattches via Brave Community brave@discoursemail.com a écrit :

1 Like

Yes! Finally got Brave to open on my Mac Mini 2018, and it seems to be (knock on wood) working OK.
Thank you.

1 Like

That worked! Thank you. I am back to using Brave on my iMac.

Sorry, worked for three days, now won’t launch. Deleted, redownloaded, followed Matches directions, but still no luck.

This apple support doc explains how to override Gatekeeper for an app you have just attempted to install https://support.apple.com/en-us/HT202491

Downloading Brave for Mac every day for the past week. Able to install, but unable to install.
This is on a Mac Mini 2018. I have Brave installed on a Mac Mini 2014 and it works fine.

After last attempt to launch, opened Brave,package contents, selected the Mac OS folder and tried to open exec file. Got this terminal message:

Last login: Fri Nov 8 12:50:28 on ttys000
/Applications/Brave\ Browser.app/Contents/MacOS/Brave\ Browser ; exit;
leebaker@Mac-mini-2 ~ % /Applications/Brave\ Browser.app/Contents/MacOS/Brave\ Browser ; exit;
[9569:54275:1110/003100.878949:ERROR:rewards_service_impl.cc(198)] Failed to read file: /Users/leebaker/Library/Application Support/BraveSoftware/Brave-Browser/Default/ledger_state
[9576:775:1110/003100.913730:ERROR:ledger_impl.cc(102)] Failed to initialize wallet
[1110/003101.212024:WARNING:process_memory_mac.cc(93)] mach_vm_read(0x7ffee897b000, 0x2000): (os/kern) invalid address (1)
[1110/003101.303247:WARNING:system_snapshot_mac.cc(42)] sysctlbyname kern.nx: No such file or directory (2)
[1110/003101.313026:WARNING:crash_report_exception_handler.cc(239)] UniversalExceptionRaise: (os/kern) failure (5)
zsh: illegal hardware instruction /Applications/Brave\ Browser.app/Contents/MacOS/Brave\ Browser

[Process completed]

Above my pay grade to understand.

@baker00,
I would recommend trying to remove all Brave files on your mac – specifically any stored in /Applications/Brave\ Browser.app/Contents/MacOS/Brave\ Browser, then re-download/install the browser and see if you get the same results.

Used Find Any File to search for all Brave files. Moved to trash. Emptied trash. Redownloaded Brave and installed. Modified System Security to allow Brave to launch. Brave starts to open, then closes.
Opened Brave package contents, went to Brave Mac Os folder and launched the terminal command there, and got the same results, along with this error message on the terminal:

Last login: Sun Nov 10 20:19:55 on ttys000

/Applications/Brave\ Browser.app/Contents/MacOS/Brave\ Browser ; exit;

leebaker@Mac-mini-2 ~ % /Applications/Brave\ Browser.app/Contents/MacOS/Brave\ Browser ; exit;

[61234:58115:1111/171746.496566:ERROR:rewards_service_impl.cc(198)] Failed to read file: /Users/leebaker/Library/Application Support/BraveSoftware/Brave-Browser/Default/ledger_state

[61240:775:1111/171746.531530:ERROR:ledger_impl.cc(102)] Failed to initialize wallet

[1111/171746.847920:WARNING:process_memory_mac.cc(93)] mach_vm_read(0x7ffee86a1000, 0x2000): (os/kern) invalid address (1)

[1111/171746.941978:WARNING:system_snapshot_mac.cc(42)] sysctlbyname kern.nx: No such file or directory (2)

[1111/171746.952071:WARNING:crash_report_exception_handler.cc(239)] UniversalExceptionRaise: (os/kern) failure (5)

zsh: illegal hardware instruction /Applications/Brave\ Browser.app/Contents/MacOS/Brave\ Browser

[Process completed]

Appears to be the same message I got previously.

1 Like

@baker00,
That’s strange – to confirm, you moved the .app into the Applications folder, correct? You’re not running from the pkg?

Yes, moved the app into Applications folder and attempted to launch from folder. Had to go to the System Preferences and change settings to allow Brave to launch. Tried launching from Finder menu: no luck. Tried launching from contextual menu: no luck. In both cases, Brave would start to launch, then abruptly close. Then, with the Brave app selected, using contextual menu, opened Package, found Mac Os folder and tried to launch the terminal .exec with the same results as before, followed my the terminal error message I reported.