Brave browser not working (Windows)

I am using brave as my default since a while. This morning it worked fine. After I closed it and opened it after a while it didn’t open at all. The steps I took to troubleshoot are given below

1.I use nightly build (I reinstalled and tried other builds)
3.Disable GPU
4.Clear user-data and doing a clean uninstall (used iobit uninstaller too)

Later I got my hands on portable version on Portable apps. It works fine but the start page is broken and there are no ads coming up (ads are 5 per hour and the notifications are on), I know about the recent post that the developers posted upon ads bit I am not sure if this is a issue with portable apps.

My PC specs
Windows 10 2004 (latest and upto date on the stable build as on 04-08-2020)
Intel i5 gen 3 (intel hd 4000 -- GPU)
8gig of ram
500 gig HDD

I use nightly build on a kali-linux machine and it is perfectly fine there.

Please provide support ASAP

So if you go to our official website and download/run the installer, then launch the app (without anything installed presently), what happens exactly?

1 Like

I have tried installing all the builds from the official website but still failed.

I did install from the official website and install it.

Installation completes successfully
When I go to any of the created shortcuts and open them the loading symbol (the blue circle next to the cursor) appears for less than a second and nothing happens). But to my suprise the portable version from portable apps works fine.

Another update.

I tried system restore to the date back when it was working. I tried to open brave but it failed. Why could this be not working even after a system restore??

1 Like

That’s very strange – can you try launching the browser with Hardware Acceleration disabled? Steps to do this can be found here:

:point_up: Note that these steps are for Windows 7 but will be the exact same for Windows 10. Let me know what you find out.

I did try that too (i even mentioned in my first thread about the steps I took). Now I am so desperate that I am hating my browsing because I loved Brave so much. If a legit support person is ready, I am ready to give remote access to him/her to solve this issue.

I even saw a thread saying sync v1 is causing some issue. Can this be it??

Yes, that can be it and would have been my next question. Do you have Sync v1 enabled at this time? If so, please launch the browser from the Terminal or, edit the application shortcut (as outlined in my previous suggestion) with the --disable-sync flag appended to the end of the target path. This will launch the browser w/Sync disabled and tell us if this is in fact the issue.

No, it didn’t work out for me.

OMG, disabling windows defender and reinstalling worked for me!!. I still dont know how did that happen

A quick final question. Brave ads are working in linux but not in windows. But in the thread it is said that it is paused for a while. When the rewards will be resumed.

Certain support resources are on hold – ads should still be showing for you on Windows. Please check our common issues/troubleshooting pages for assistance:

thanks for sharing that and glad it fixed and have a nice day

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.