Brave browser just doesn't (can't even open)

One day when I updated my pc, brave just refused to work for no reason, it just didn’t open whatsoever, I’ve tried basically every single tip that this forum has given me, and none of them have worked

I’m using Windows 10 21H2 and attempting to use Brave 96.1.33.106

i’ve already tried a clean reinstall
i know that i haven’t downloaded any malware
i’m currently doing a system check
i know my disk storage is not full
so i don’t know what to do

i’ve just finished the scan and nothing’s changed

@teamkilled,
Can you elaborate a bit on what happens when you do try to open it? Does it start to open then crash? If so, are there any crash notifications/error messages? If not, does the app look like its going to open but then nothing happens? Is it completely unresponsive? Did this only happen after updating to v1.33.106 or were you able to use this version before the crashing began?

I’m having the same problem on multiple machines, WinX and an Android phone. This seems to have started around the last update. I"ve done multiple reinstalls.