Brave browser hangs while loading different sites

Brave began stalling or waiting for some aspect of a page to load on certain sites, a couple months ago.

For instance eBay’s main page always stalls for 10 to 20 seconds while it seems to try to load their slideshow banner ad. But if I try to log onto my bank site the page will completely stall at the logon page waiting for a page called cfa.*.com to load. I assume it has something to do with the customer service chat widget which loads last.

This has also started happening on the Spectrum.net page, among others.

I have un-re-installed Brave and cleared the cache and deleted related cookies for the affected sites.

None of this occurs on plain vanilla Chrome, which I also have installed. This has become so troublesome that I am seriously considering dumping Brave altogether and going back to Chrome.

Could you be having this issue? Infinity load in random pages ( ⇦ Slow loading or No loading)

2 Likes

Try Aggressive mode @Jimmersd

For Spectrum, try adding spectrum.net##+js(acis, tmx_post_session_params_fixed) into brave://adblock

It seems like it might be the same.

I have Trackers & ads blocking set to Standard and Block fingerprinting disabled. :thinking:

Is it same in a new profile as well- Create a new profile to help Troubleshoot ?

I just tried a new profile and was able to logon to the site with no problem. I noticed that shields were up by default on the login page in the new profile. So I went to the old profile and turned the shields on for the same page and the problem stopped. I am now able to logon.

Curious. I see with shields off for this particular site everything freezes when the Customer Service ap icon pops up in the lower right hand corner. Shields stops it from becoming active. I’m pretty sure it’s the culprit here.

I’ll try the same with other sites. Bank and bill pay sites don’t tend to play well with ad blocking on though. Unusual that it does here.

@Jimmersd,
I would open the Shields panel and toggle the individual protections on/off to check and see which one of them is causing the issue.

1 Like

@Jimmersd

In the following settings and illustrations, some of the settings are temporarily set for difficult website connections involving a Sign-In. IF temporary, I’ll note that: (temporary).

At: brave://settings/security:

  • DISABLE: Always use secure connections (‘HTTPS Only’ toggle switch) (temporary)
  • DISABLE: Use secure DNS

I use Brave Shields v1; and, at: brave://settings/shields

  • DISABLE: Auto-redirect AMP pages (always)
  • DISABLE: Prevent sites from fingerprinting me based on my language preferences (temporary)
  • Trackers & ads blocking: Standard (temporary - usually Aggressive)
  • Enable: Upgrade connections to HTTPS (‘HTTPS Everywhere’ toggle switch) (always)
  • DISABLE: Block scripts (temporary - usually ENABLED)
  • Block fingerprinting (aka Fingerprinting blocking): STANDARD (temporary - usually Strict)
  • Block cookies (aka Cookie blocking): Only cross-site (always)

hi all

I’ve got the same issue as the OP…trying to log into at least two different (secure) banking websites, causes Brave to stop responding - there is a blinking cursor, in the first box one can enter your password into, but as soon as you try to enter a character, the box “blanks” and the browser stops - and the browser then shows a message from the website to “wait”…and this repeats a few times. Eventually, maybe after 4-5 minutes you CAN enter the password…

Switching to Google Chrome and it works perfectly straight away.

I have switched all manner of Brave Settings and Security options on and off, and none solve the problem - so here I am reporting it !

(Running: Version 1.40.105 Chromium: 103.0.5060.53 (Official Build) (64-bit)

Any ideas anyone?

regards and keep staying safe

@timbo2022

Some notes, before proceeding

  • A digital certificate problem might be involved re failure to Sign In
  • A VPN might be involved re failure to Sign In
  • Might help to use a Brave Browser > New Private Window
  • One or more Extensions might be involved re failure to Sign In

Include the Brave Browser Settings temporary adjustments at:

In a Brave Browser > New Window, go to: brave://settings/clearBrowserData

For tab Advanced

  • Set: Time range:All time
  • Enable: Browsing history
  • Enable: Cookies and other site data (Signs you out of most sites)
  • Enable: Cached images and files
  • Enable: Autofill form data

Click on the ‘Clear data’ button.

(The ‘Clear data’ button also saves the selections.)

Recommend Brave Shields v1

In a Brave Browser > New Window, go to: brave://flags

Search, there, for: Enable Brave Shields

  • DISABLE: Enable Brave Shields v2
  • ENABLE: Enable Brave Shields v1

In a Brave Browser > New Window, go to: brave://settings/cookies

Scroll down that settings page, to Sites that can always use cookies

Click the Add button

Enter [*.]somebank.com as the site . . . but Do Not Enable:

  • Current Private session only
  • Including third-party cookies on this site

Click the Add button

Repeat those steps for:

  • [here I would list additional sources, if / when discovered - see Developer Tools]

Next, go to: brave://settings/content/javascript

Scroll down that javascript settings page to Allowed to use javascript

Click the Add button

Enter [*.]somebank.com as the site . . . but Do Not Enable:

  • Current Private session only

Click the Add button

Repeat those steps for:

  • [here I would list additional sources, if / when discovered - see Developer Tools]

In order to learn, what website sources (of Cookies and JavaScripts) may be involved, learn to use the Developer Tools > Network tool for monitoring items, and use the Developer Tools > Application for learning sources of, and examining, Cookies.

How to use Developer Tools

Cookies check

In a Brave Browser > New Window, go to: brave://settings/cookies and in the upper-right area of the window, enter into the Search field: somebank

Then, search down the cookies settings page and check to see if somebank shows under Sites that can never use cookies . If exists, then remove the somebank entry.

JavaScripts check

In a Brave Browser > New Window, go to: brave://settings/content/javascript and in the upper-right area of the window, enter into the Search field: somebank

Then, search down the javascripts settings page and check to see if somebank shows under Not allowed to use javascript. If exists, then remove the somebank entry.

Clearing DNS cache

Option A

In a Brave Browser > New Window, go to: brave://net-internals/#dns and click on ‘Clear host cache’

Next, go to: brave://net-internals/#sockets and click on both of the following (in succession):

  • Close idle sockets
  • Flush socket pools

Exit / Quit Brave Browser

Exit / Quit everything else and Restart your computer.

Option B

How to flush DNS cache in Windows OS: ‘https://www.wikihow.com/Flush-DNS

How to flush DNS cache in Mac OS: In a Terminal.app window, enter at the prompt:

dscacheutil -flushcache

Exit / Quit everything else and Restart your computer.

Notes re what are:

DNS cache:

Socket pool:

With pooling, instead of closing a connection after it is used, we can keep it idle while it waits to handle another request. This saves the resources required to create a new connection.

@timbo2022 can you enable brave://flags/#enable-prerender2 , restart Brave. see if that helps?

Ref.: