Citibank online freezes for a few seconds

Description of the issue:

Citibank website freezes for about 10-15 seconds while it tries to load, unable to click anything while it does. Has always been happening with Brave, since I can remember using it. Shields are turned off for the site.

How can this issue be reproduced?

  1. Log in to https://www.citi.com/ or https://online.citibank.com

Expected result:
Expect normal load times

Brave Version( check About Brave):
1.40.113 , chromium 103.0.5060.114

Additional Information:

64bit Windows 10 21H2

Is shields enabled, Ads/trackers?

The shields are off, I enabled popups, I disabled adblocking (Ads set to allow). The only thing blocked is insecure content.

Enabled ads/trackers in shields, they’re doing portscans/fingerprinting which will impact performance. Just use standard, see if it helps

1 Like

What do shield settings matter for this if shield is off? I do not get this kind of lag in Chrome by the way. I was monitoring loading using the developer tools and there are some kind of blob:https://online.citibank.com stuff hanging it under javascript category.

Just to let you know, problem still is present. Thanks.

Waiting on a response on my first post, enabling shields on the site. It should counter the freeze.

1 Like

Ok I didn’t know you wanted the shields on, sorry. Yes, I can confirm with the shields on that the freezing goes away. I normally turn off shields for financial websites as I have ran into features not working on the website but I’ll keep the shields on for citi bank stuff. Thanks.

2 Likes