Brave 100% CPU Usage + Refusing to Quit

Description of the issue:
Recently, upon launching the Brave Browser on my MacBook Pro, I see high (100%) CPU usage immediately (consistently for the duration the application is open) and my laptop’s fans ramp up. No tabs are open. Also when I try to quit Brave, the application does not quit immediately. I must Force Quit it from Activity Monitor before it finally quits.

Brave Task Manager:

Activity Monitor:

How can this issue be reproduced?

The problem occurs immediately upon opening the Brave Browser Application.

Expected result:

Regular CPU behavior (typically much lower than 100%).

Brave Version( check About Brave):

Version 1.16.68 Chromium: 86.0.4240.111 (Official Build) (x86_64)

I’m also on the latest version of macOS (10.15.7)

Additional Information:

This is very new and was never happening before. I uninstalled and reinstalled the browser but was faced with the same issue. I found a similar issue on the forum from a few months ago about the Grammarly extension potentially causing an issue, so I disabled the extension but the problem persists (in any case, I think the issue was resolved on Grammarly’s end). I’m unsure what is causing this problem or how to fix it.

1 Like

I can confirm that this issue is specific to Brave and doesn’t depend on any user configuration or extensions since it still uses 100% CPU after clearing all local configuration and the same chromium version used by this version of Brave doesn’t have this issue. I tested this on Linux so it’s not specific to macOS, but could be only affecting Unix-like operating systems.

Edit: weird, it seems to be fixed now.


So strange, it just stopped shooting to up to 100% usage. Brave also quits fine without any issues now (???). No idea what caused it (or fixed it), but I suppose this is resolved for now.

I had the exact same problem yesterday, except on the Windows version of Brave. I tried several things, including closing all tabs, disabling all extensions, and rebooting the computer, but it still persisted. Then I cleared Brave’s cache and the problem went away immediately for some reason.

1 Like

@anondev (and anyone else in this thread),
Can we confirm whether or not the issues persists or if it appears to be resolved?

1 Like

@Mattches I’ve been using it regularly since and everything seems to be working fine on my end; the issue appears to be resolved. Thanks for following up.

1 Like

Thank you for opening the issue and apologies for getting to it so late.
Please don’t hesitate to reach out if this or any other issues appear.