Brave Browser Helper (Renderer) - 100% of CPU

I am new here - have tried to find this issue, but haven’t located a thread for it.

I am having a persistent problem with the Brave Browser Helper (Renderer) consuming 100% of my cpu. I am using

  • a MacBook Pro (2014 model) with OSX 10.11.16.
  • Brave version is Brave is up to date -mVersion 0.68.132 Chromium: 76.0.3809.132 (Official Build) (64-bit)

I have turned off Hardware Acceleration, but that has not fixed the problem.

Any other suggestions?

I have having the exact same problem. The only way I can fix it is to go into activity monitor and manually stop the Brave Helper.

I’ve only recently downloaded Brave browser and I love it. However, this bug will make it unusable for my purposes.

I’ve discovered that the problem gets much worse on when I have certain tabs open.
Wall Street Journal is one of them that causes the spike: https://www.wsj.com/

I have been using Brave for a few months now, and just upgraded to a new MacBook Pro with 8 cores and 32 Gig of ram. I have a TON of browser tabs open (easily 150) in 9 windows total at the moment. But for the last few days I have suddenly had my fan going at full blast when Brave is running. Checking process monitor it is clear that it was a Brave Helper process that was pegging CPU at 100%!!! I think this started when I was watching a couple of youtube videos, but can’t be certain. I ended up downloading an extension to put tabs to sleep, which didn’t help at all. I had already closed the youtube tabs (before installing extension) that I had open, with no improvement.

The only thing that worked was killing the Brave helper process. Not sure of next steps, but I am happy with Brave, and am fully behind the project and its vision, so I am truly hoping there is a solution to this problem (looks like it has been around for a while judging by some of the hits I got in my Google searches).

A couple of additional notes:
Brave version 0.70.122
I am using Mac OS Catalina
I had only two extensions installed and active (Last-Pass and Ublock Origin)
Lastpass MAY HAVE BEEN the cause, though I can’t be sure, and it is not new to my workflow.

Same with me. Happens with a few websites, the most recent being Nextdoor.com. Must be a Mac issue?

Mac mini (mid2011)
macOS 10.13.6 High Sierra
Brave Version 0.70.122 Chromium: 78.0.3904.87 (Official Build) (64-bit)

I am having similar issues. For example loading a new webpage from a new tab takes forever, but once it is loaded it works fine.

MacBook Pro 2018
mojave 10.14.6