Tutorial - Solve Blurry Brave Contents - W10 - 4K or 1080p screens

Three are the points where the Issue can be generate: Brave, Windows, Nvidia.

1) First check your Brave is it using acceleration in Settings

brave://settings/system

Search “Acce” then > disable Hardware Accelleration.

After disabling restart you Brave (you can kill it via Task Manager)

If that’s not enough to solve the blurriness we have two more way to go:

2) trying via Windows
Right click on you brave Icon and choose properties:

Then follow picture going to Compatibility tab:

Change Dpi checking the first option then selecting System (enhanced) on the second one

Click ok, ok ,ok - when everything is closed - Restart your Brave

Not yet the very perfect results ???

Let go to Nvdia then !!!

3) Right click on desktop choose Nvidia Control Panel
(you’ll find it, the same, also in W10 Control Panel)

Go to Manage 3D Settings
and after changing TAB AND CHOOSING BRAVE in the drop-down menu
…Follow what’s on the pic:

Restart Brave and Check…

My experience tell me that there are three points where the issue is generate,
but please if you find something different let me know!!!

Happy to hear if it was useful

Alain

PS: Lost the piece of paper where I noted all the procedure last time I built a PC,
took three months and many bangs on different walls…
—till few minutes ago when I found the paper inside previous PC—

So - I decided to write it online so next time I will not go crazy again…
… and may be some other can benefit from my own painful experience

(QantoPurple: Amd 5600X, MSI B550, 32G @3200, MSI TRIO 2070s)
(aWhitePC: Intel 8700K, Gigabyte Z390, 16G @3000, Gigabyte OC White 2070)
Both share via KVM the same screens:
(Samsung 4k 8000 65" 120H + Samsung 32" + Samsung 27")

1 Like

Interesting ideas @AlainCh2 If you’re using a high-ish end system (decent GPU), disabling hardware acceleration maybe a bad idea?