Black screen when opening on MacBook Pro

Hi,

Within the last day, whenever I open Brave Browser, I just get a completely blank window (screenshot attached). I’ve tried uninstalling and reinstalling, and also tried the Beta and Nightly versions – same thing happens. Right now, I’m on Safari (which works fine). I’ve never had this issue before, and am not sure how to proceed.

Thanks for your help!


Description of the issue:
How can this issue be reproduced?

  1. When I open Brave on my MacBook Pro, a black window appears.
  2. Trying to open a new tab, switch profiles, click “Preferences,” etc. does nothing.
  3. Uninstalling/reinstalling also does not fix the issue.

Expected result:
The application opens as usual.

Brave Version( check About Brave):
91.1.25.68 (obtained from disk image)

Additional Information:
macOS Mojave version 10.14.6 (18G9216)

Hey Joe_Doe,

If you’ve already completely uninstalled/reinstalled your browser, then I would suggest completely wiping all trace of Brave from your PC, then redownloading the installer and installing it again.

HI @Adrian_02,

Thanks for the suggestion, but unfortunately, this did not fix the issue.

I deleted the app from the Applications folder and everything from ~/Users⁩/(user)/⁨Library⁩/⁨Application Support⁩/BraveSoftware before re-downloading/re-installing.

In that case, open the Terminal and enter this command: open -a "Brave browser.app" --args --disable-gpu.

Hope I’m not crashing the party but I’m having the same issue. Also a MacBook Pro running Mojave 10.14.6 and Brave 91.1.25.68.

I tried “open -a “Brave browser.app” --args --disable-gpu” in Terminal but the windows in Brave were still blank.

Then I scrounged an older version of Brave from GitHub – version 90.1.23.68. After deleting ~/Library/Application Support/Brave Software and setting up sync again I’m back in business.

After downloading the previous version, were you able to update the most recent version?

Hi @Adrian_02,

Unfortunately no, running the Terminal command didn’t resolve the issue. It looks like it tried to load (see screenshot), but ultimately didn’t.

However, I tried the same thing that @Quinnat mentioned above (installing version 1.23.68 from GitHub), and that version works perfectly fine.

EDIT: Also, no, installing 1.23.68 then upgrading to the latest version still resulted in blank screens.

Glad to hear @Joe_Doe you have it working. I would have been willing to try upgrading to the latest version but since it didn’t work for you I’ll avoid updating for now! :slight_smile:

1 Like

I forgot to specify, but did you run the Terminal command after completely closing all instances of Brave?

Also, can you check if Chrome is having the same issues? I’d just like to check if this is a Chromium issue, or if it’s Brave-specific.

Yes, I ran the Terminal command after completely closing all instances of Brave. I also just downloaded and tested Google Chrome and it had the exact same issue.