Audio lags when multiple tabs/renderers are created

Description of the issue:

Audio begins to lag behind by many seconds if Brave launches renderers in the background by opening tabs on certain websites.

Opening Task Manager and killing the Audio Service resynchronizes audio for a while, but then it goes out of sync again if the tabs are not closed.

The tabs do not even need to be fully loaded by visiting them. They just need to be cmd+clicked to load in the background and the audio will start to go out of sync.

Oddly, this doesn’t happen when opening multiple tabs from websites like youtube, but it does happen on shopping webites that may be loading lots of tracking scripts, like aliexpress and amazon. Doing this will inturn cause youtube audio to start lagging, as well as system audio from locally played files.

Brave seems to be hijacking the BT audio queue or something.

How can this issue be reproduced?

Connect BT audio/headphones… browse around youtube. load up some vids in some tabs… browse around aliexpress and open tabs in the background…

go back to youtube videos and after a few vids, the audio will continously drift or lag by a long delay, sometimes upwards of 3 seconds.

Brave Version:
Version 1.51.110 Chromium: 113.0.5672.77 (Official Build) (x86_64)

Additional Information:

I’ve installed a chrome extension called ‘enhanced-h264ify’, which is a fork of ‘h264ify’ with a few more options.

it seems that vp8/vp9/av1 encoding goes out of sync if hardware acceleration is enabled as @Mattches has pointed out in this thread:

however, that is not a suitable fix because some websites require hardware acceleration to run at a reasonable speed or reasonable CPU usage level.

Will there be a fix that still works with hardware acceleration and VP/AV playback at some point?

Thank you for reporting.
I can reach out to the team about this and see what is possible — however, I actually cannot reproduce the issue on my macOS system. Are there very other specific steps to reproduce this issue other than what I’ve done below:

  1. Ensure that HWA is enabled in the browser
  2. Open up Youtube and start watching video content
  3. Open new tabs to Amazon
  4. While YT video plays, browser around amazon, open some links from Amazon in new tabs
  5. Return to YT to see if audio lag is present

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.