Continuation of previous Audio-Lag Thread

My last thread had closed because
I did not receive email notifications regarding any responses, also every time I log in to brave community with Brave Browser I am unable to click on any links. I have disabled all extensions and still same issue. I am now using icognito mode and it works for some reason now.

Anyway, here is the link.


please try with aliexpress on macOS if possible.

This has been an ongoing issue for at least a year now for me. It seems that when a website creates a bunch of “renderer” or “subframe” instances, audio is delayed by seconds (not miliseconds) on youtube.

to recreate:

  • browse on youtube.
  • go to aliexpress.
  • open a few tabs of some products
  • wait a few minutes
  • go back to youtube
  • open a different video in a new tab
  • audio is delayed by 2-5 seconds.

Following these steps exactly I cannot reproduce the issue. This is using the latest version of the browser on macOS (Ventura 13.4.1). To confirm I performed the right steps to produce the issue, I did the following:

  1. Open Youtube and started playing a video (
  2. Opened a new tab and went to
  3. Browsed for a moment and opened a few products in new tabs
  4. Stayed on AliExpress for a moment and seriously considered purchasing a vertical ergonomic mouse
  5. Returned to Youtube and opened another video from the related content section in a new tab (

I experienced no audio lag and everything seemed to be working as intended. In your original thread, you mentioned that both that disabling HWA resolves the issue and that you’re using the enhanced-h264ify extension. Can you please confirm that disabling HWA still resolves the issue and whether or not disabling that extension has any effect?

I’ve asked some team members to try and reproduce the issue as well in the meantime.

Additionally, can you please tell me whether or not you see this behavior:

  1. When trying to produce while using a Private browsing window
  2. Trying to reproduce with a new browser profile

I’ve since disabled the enhanced-h264ify extensions.

This is with bluetooth headset, by the way.

Disconnecting and reconnecting the BT headset causes the audio to sync up again. Also performing End Process on “Utility: Audio Service” from Brave’s task manager resets the audio and syncs it up again as well.

Videos playing in tabs have to be refreshed sometimes after ending the Audio Service utility.

To me it seems like something is hijacking BT audio stream when there are tabs on specific sites open? I don’t know the inner workings but I will try your recommendations this afternoon and report back.


I can confirm that the issue persists when performing the following:

  • Turn off BT Headphones.
  • Turn off computer.
  • Turn on computer & boot into macOS BigSur.
  • Turn on & connect BT Headphones.
  • Open Brave and make sure no old tabs are open.
  • Open New Private Browsing Window.
  • Go to Youtube and browse some videos with people/faces talking
  • Confirm audio is synchronized with mouths moving.
  • Open a few more youtube tabs of random other stuff.
  • Go to Aliexpress, browse some items by creating new tabs.
  • Actually go to the opened tabs to make sure they are loaded fully.
  • Close a few tabs, open some more on Aliexpress (15 total approx.)
  • Go back to Youtube, open a few more tabs of vids with ppl talking.
  • Audio is now out of sync, anywhere from 2 to 4-ish seconds.

If I download the video from youtube and play it in a player like MPV or IINA, it will also be out of sync now.

Is brave causing too many audio streams to be queued on the BT Stack or something.

BT Headphones are like 4 feet from receiver. I can walk 20 feet away in macOS or windows 10 and it’s fine.

Windows 10 does not exhibit this sync problem as far as I am aware.

Is there anything I can check in Bluetooth on macOS to see if it’s not browser related?

1 Like

Thank you for all the detailed information here and apologies for the late reply. This is honestly super strange behavior and I’m unclear on the cause. Let me confer with the team about possible causes and the next best ways to troubleshoot this issue.

I am curious however as to whether or not this issue occurs if you’re not using your BT headphones? If you are using standard speakers (and/or wired headphones) do you see this same behavior?

Thank you

that would be a little difficult for me to test as I cleared out all my wired old stuff long time ago. I’ll see if I can borrow a set, but that is indeed a good test that I should do in the meantime.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.