Brave Tab Interaction Slow On Linux

Description of the issue:
Hi, I recently started using Brave. I really like the clean UI design and ad blocking, but I’m experiencing extreme sluggishness when opening/closing and generally interacting with tabs. I believe it’s related to rendering. It happens with any website (even the new-tab page), but is more prominent when something like YouTube or Netflix is open. When opening a new tab, the tab “loading” icon is incredibly choppy, it takes a 15-30 seconds to fully render, and any videos in other tabs/windows come to a halt (although audio normally continues normally). If I open a YouTube video link, it will begin playing, but the page will, again, take 15-30 seconds to render. I’ll just hear the audio. In that time, if I click where the video will eventually rendered, it pauses (e.g. the site is working, but taking forever to render).

As some background, this is a fairly clean Brave installation with only one plugin installed (LastPass). I’m running on Arch Linux on a Dell XPS 15. I run the dwm window manager with no desktop manager. I’m using a dell dock with 3 external monitors all at 1080p (internal display is disabled). However, I’ve seen this issue even when only utilizing the internal display and no external displays.

I haven’t found anything online about a similar issue through searching around, so I assume this is something with my specific setup or configuration. I’m curious if anyone here has any ideas of what might be causing it? Thanks!

How can this issue be reproduced?

  1. Install Brave
  2. Open Brave
  3. Open a new tab

Expected result:
Tabs open relatively quickly, and switching between open tabs does not cause any lag or lockup of Brave.

Brave Version( check About Brave):
The “About Brave” page lists version 1.15.72 w/ Chromium version 86.0.4240.75 (Official Build).

Hello @calebstewart

could you update to the latest version as the latest is 1.16 and check if it still the same issue or not

if it does not work could you disable hardware acceleration and see if it help

could i ask how many tabs you open?

hope that help and have a nice day


I also came here to suggest turning off Hardware Acceleration:

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration


How did you install Brave …
Arch repo?
Running a Snap version?
Some other method?

It looks like this was the problem. It’s noticeably more snappy now. I had looked for that setting, but for some reason couldn’t find it before. I feel a little silly. Do you have any idea (or links to resources to learn more) about why this is the case? The XPS 15 has GPU, so I would expect this to be a good option to have enabled. I’m curious if maybe another configuration on my underlying system is causing it not to play well with hardware acceleration.


1 Like

HWA has been causing issues for some time now, but it’s been hard to nail down the exact cause. The devs are aware and hope to resolve the issue in future releases.

1 Like

Just to be clear, that setting is also available in the core Chromium browser[1], and in Chrome. AAMOF, if you google this
“chromium chrome hardware acceleration slowness”
… you’ll see where lots of folks have / had the issue.

[1] Chromium screenshot (running on Linux)


Okay, I don’t use Chrome or Chromium, so didn’t know. Thanks.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.