Attention: For those of you experiencing consistent crashes on version 1.3.113

Users still running Brave version 1.3.113

If you’re still using Brave version 1.3.113, you’re likely still encountering frequent crashes when launching the browser. The source of the crashes has been linked to an issue with Brave Sync and is currently being addressed. In the meantime, we have new builds ready that contain a hot-fix for the issue (v1.3.115) by temporarily disabling Brave Sync.

Note that Sync will only be disabled until the root cause of the issue is resolved. Until then, please download and install the updated builds from our Github here:

1 Like

Note that Sync will only be disabled until the root cause of the issue is resolved.

Why?

Prior to v1.1.23, adding the flag –disable-brave-sync to the target (desktop / Start menu) in the shortcut did what one might expect: disable Brave sync.

Give users choices.

Just installed 1.3.115. No issue to report. I do not use sync anyway. But most do so hope there will be a fix soon.

@Mattches how about adding Sync to the “Known Issues” section of the forum?

2 Likes

Hi Folks, Brave does not run any more on my MBP (OSX 10.14). Immediate crash following the installation of 80.1.3.115. Opens a window, hides the small (Brave) crash report window. Occasionally a window appears, shows no bookmarks etc. Then crashes.

Cannot find a crash report. This is from Systems Log (search Brave):

Feb 11 07:30:30 MacBook-Pro com.apple.xpc.launchd[1] (com.getdropbox.dropbox.garcon.32FA139D-19F3-4F37-9092-E81B78D94796[24812]): Caller wanted oneshot behavior for pre-existing instance: caller = Brave Browser
Feb 11 07:30:30 MacBook-Pro com.apple.xpc.launchd[1] (com.getdropbox.dropbox.garcon.9B269566-58D2-46CB-875C-E33DDD4FF435[24816]): Caller wanted oneshot behavior for pre-existing instance: caller = Brave Browser
Feb 11 07:30:40 MacBook-Pro com.apple.xpc.launchd[1] (com.getdropbox.dropbox.garcon.4CE688FA-A79B-4318-A831-98654334961F[24898]): Caller wanted oneshot behavior for pre-existing instance: caller = Brave Browser
Feb 11 13:37:56 MacBook-Pro Brave Browser[573]: BUG in libdispatch client: mach_recv, monitored resource vanished before the source cancel handler was invoked { 0x7f9d9847d950[source], ident: 79107 / 0x13503, handler: 0x110cb74e0 }
Feb 11 13:37:58 MacBook-Pro AGMService[676]: ProcessPath : /Applications/Brave Browser.app/Contents/MacOS/Brave Browser
Feb 11 13:38:07 MacBook-Pro com.apple.xpc.launchd[1] (com.brave.Browser.65464[32342]): Service exited due to SIGSEGV | sent by exc handler[32342]
Feb 11 13:38:10 MacBook-Pro AGMService[676]: ProcessPath : /Applications/Brave Browser.app/Contents/MacOS/Brave Browser
Feb 11 13:38:50 MacBook-Pro com.apple.xpc.launchd[1] (com.apple.xpc.launchd.oneshot.0x10000029.Brave Browser[32441]): Service exited due to SIGSEGV | sent by exc handler[32441]
Feb 11 13:38:54 MacBook-Pro AGMService[676]: ProcessPath : /Applications/Brave Browser.app/Contents/MacOS/Brave Browser
Feb 11 13:38:55 MacBook-Pro com.apple.xpc.launchd[1] (com.apple.xpc.launchd.oneshot.0x1000002b.Brave Browser[32717]): Service exited due to SIGSEGV | sent by exc handler[32717]
Feb 11 13:39:05 MacBook-Pro AGMService[676]: ProcessPath : /Applications/Brave Browser.app/Contents/MacOS/Brave Browser
Feb 11 13:40:12 MacBook-Pro com.apple.xpc.launchd[1] (com.brave.Browser.65496[32822]): Service exited due to SIGSEGV | sent by exc handler[32822]
Feb 11 13:42:25 MacBook-Pro AGMService[676]: ProcessPath : /Applications/Brave Browser.app/Contents/MacOS/Brave Browser
Feb 11 13:42:26 MacBook-Pro com.apple.xpc.launchd[1] (com.apple.xpc.launchd.oneshot.0x1000002f.Brave Browser[34015]): Service exited due to SIGSEGV | sent by exc handler[34015]
Feb 11 13:44:52 MacBook-Pro AGMService[676]: ProcessPath : /Applications/Brave Browser.app/Contents/MacOS/Brave Browser
Feb 11 13:45:07 MacBook-Pro com.apple.xpc.launchd[1] (com.brave.Browser.65632[34898]): Service exited due to SIGSEGV | sent by exc handler[34898]

HOW DO I SENT In A CRASH REPORT? Doesn’t let me, copy/paste does not work because it is too large.

R.

@rlfsoso,
If you’re able to keep your browser open, you can go to brave://crashes and send the crash reports manually that way. If you want or need to copy/paste them into the forum, use as site such as pastebin to do so.

Hi, Brave still crashes on me. Usually very fast, sometimes showing the outline of a window, then a beachball followed by a crash.

https://pastebin.com/YaH78nXs

Hope that helps.

1 Like

@rlfsoso assuming you don’t have a chance to go into brave://crashes and grabbing the Crash Report ID? Does Brave crash pretty instantly?

Just curious, if you run Brave via the terminal using the following, does that stop the crashing?

/Applications/Brave\ Browser.app/Contents/MacOS/Brave\ Browser --disable-gpu

Hi,

reporting: the gpu disable did no change: Brave opens, blank (no bookmarks or tabs load) window opens, after a second the beachball appears crash. System crash reporter opens.

what else to do?!

Something else:
went to local/library/application support/brave browser
and removed everything there.
Started Brave, showed up a tiny bit longer, showing a window “Brave was ended last time because of a problem, do you want to try to open older windows” [sorry that’s about]. In front of the well known blank window.

Then the beachball, and crash/systems crash report. I was not fast enough to get a screenshot, though.

What else can I do?!

@rlfsoso,
I’m wondering if there’s something specific to your browsing profile that’s causing the issue. Can you try right-clicking on the Brave icon and selecting New Private window from the context menu and see if the browser launches/stays open?

Also, if you’re willing, I would try downloading/installing the Brave Beta build and see if you get the same results. Note that downloading the Beta will not overwrite or delete any of your previous installation data.

Hi @Mattches,

just to start with, I am not very savvy with all this, sorry. But when right clicking on the Brave icon I cannot see the entry “new private window” (see screenshot below)

Brave really just suddenly stopped working, following the update. The only other thing which got updated around that time frame was Flash on my system.
Cheers, will check again tomorrow afternoon, tomorrow on early shift.
Rolf

Hi @Mattches, now the beta… same new same old, sorry: screenshot bevor the crash:
exactly the same, a second later, beachball. Hopefully you will now directly get the crash report. Now off! R.

@rlfsoso,
In your first screen shot, it looks as though maybe you’re launching the browser from the .dmg directly – is that the case? If so, add the icon to your dock instead and right-click it there. You should see a different context menu with different options, something like this:

However, given your second screenshot, I’m thinking the problem is of a different nature. I’m going to have you try to launch the browser from the Terminal (command line) with a specific flag that disables a feature called Hardware Acceleration, which has been known to cause similar issues for some users. The task is not as intimidating as it may look – I’ll walk you through each step:

  1. On your mac, press cmd + spacebar to open spotlight search.
  2. Search for and launch your system’s Terminal application.
  3. In the terminal, enter the following command exactly:
    open -a "Brave Browser.app" --args --disable-gpu 
    
    Here’s how it looks in the Terminal:
  4. If the browser window launches and stays open/does not crash, go to Menu --> Settings --> System --> Hardware Acceleration and toggle this option “off”

If the browser does launch but then crashes as it has before, I’d suggest again trying to launch a private window and see whether or not you get the same results. Note that you can do this the way I mentioned above by adding the icon to the dock and right-clicking – but since we just went over it, you can also do this from the Terminal as well by altering the command you just used to be:

open -a "Brave Browser.app" --args --incognito

Let me know what you find out.

Hi @Mattches, many thanks for your long reply. Indeed that seems to have solved my problem: launching with the gpu disabled gave me back my starting window (since I emptied my user specific folder in application support it started from scratch).
The curious thing is that the Brace beta, installed side by side started as well and crashed in the well known manner first, and then the regular Brave app opened with thew welcome window mentioned above. I manually disabled hardware support and all has been well since. The beta still crashes though (crash id is: e668946a-0df9-45a0-a41e-0f4f8a9aa01c if that helps).

I really needed to get my mind around conventions here, like where to look for crashpad and stuff. Perhaps it’s safer not so assume that users immediately know about these things when they try to report a problem. Now I know (sort of) and will hopefully be more able to support all your programming efforts.

One thing: I did notice how much I already got used to Brave as my standard browser compared to Safari, though there still are some quirks, like typing in part of a bookmark, matches with Safari are faster and more to the (right) point even though I imported all my bookmarks from Safari.

Thanks again,
cheers, Rolf

1 Like

Hello,
in case someone can’t even open Brave because of this compatibility issue, here’s a fix:

In the file explorer navigate to;
C:\Users\yourusername\AppData\Local\BraveSoftware\Brave-Browser\User Data
Open the Local State file (using Notepad for instance)
Look for brave-sync@1 (3rd line for me)
Set the 1 to 0.
Ctrl+S to save
Close file and launch Brave

1 Like