Another "Not getting ads on Windows 10" post

I am a new Brave user, and I haven’t ever gotten my desktop Windows 10 Brave install to show an ad notification.

I’ve been reading lots of other posts about this over here and seeing the lack of responses it’d really make a big change of my impression about the usability of this feature or the support Brave can give on this - which as you can imagine isn’t exceedingly positive. At first I was excited about the switch to Brave - rewards was a factor in that decision - now it’s starting to wear off quite quickly.

I’ve turning ads off and on closing Brave multiple times, tried resetting my wallet (both from “brave://rewards → Manage your wallet → Reset” and from “Settings → Wallet → Reset wallet”) lots of times, made multiple reinstalls clearing registry entries and %appdata% brave folders, even tried installing nightly.

Brave Notifications are enabled on W10. shows them perfectly fine.

I’ve also checked and checked there’s > 15 campaigns running right now.

My rewards-internals log shows lots of recent] Failed to get signed tokens

and] Publisher info not found


Rewards-internals ad diagnostics shows

Ads enabled: true

And General info shows

Key info seed: Valid
Wallet status: Not connected

My wallet isn’t verified yet because it never had any BAT to go with Uphold’s 25 BAT requeriment.

I am seeing ad backgrounds on Home Tab pages, and they’re showing on the “30-day history” in “brave://rewards”. However, it also shows there

Current earnings this month (estimated) 0.000BAT 0.00 USD
Ads received this month 0

On my Android everything is apparently working fine, and I get an estimate there of around 0.25 BAT which seems to be correct.

I am not on a VPN. I’m running W10 on a VM. My home router has Adguard Home installed but that’s not likely to be a problem because Android gets ads while on the same network too.

Is there any more information I can provide? Can anyone help with this?


@Drakkos I get ads on windows 10 but dont get any Bat for the ads that I see
My rewards-internals log shows this

[29 Jan 2022, 9:10:50.8] Failed to get signed tokens
[29 Jan 2022, 9:11:46.2] Token list empty
[29 Jan 2022, 9:11:46.2] Transferring tokens failed!
[29 Jan 2022, 9:21:13.7] Token list empty

I have uninstalled Brave and installed Nightly again afterwards, and as of now the results are the same.

I still haven’t got any ad notification (they are enabled and showing for other sites), but at least homepage ads are apparently accounted for in “brave://rewards”. They show in “Current earnings this month (estimated)” and also in “Ads received this month”. With normal Brave they both showed always 0, even though the homepage ads appeared in the “30-day Ads History”.

If I need to use Nightly I will but I’d like to avoid it if possible. Anyone know how these symptoms explain what I’m experiencing?

I am on a W10 VM, and apparently Brave (both regular and Nightly) show as managed. In both of them the “Use secure DNS” is disabled and reads “This setting is disabled on managed browsers”.

I do use a VPN occasionally for professional purposes but it doesn’t change my location. I also like to use Brave in English even though my region and windows locale isn’t English (they do match each other).

Can anyone help with this puzzle?

I finally got ad notifications showing up and being accounted for using Brave Nightly. Didn’t make any change or anything different.

Would still like to know why Brave Official can’t show me ad notifications or reward for home page ads it displayed.

I tried switching back to latest Release (1.35.100) and the situation is still the same. Got no notifications, and homepage ads were showing but not credited.

I’ve found the SQLite database and in ad_events it’s only creating click events for the new homepage ads (when I click on them). When I was running Nightly it also created viewed and served events which are missing in this table. I am attaching a screenshot of the table, hope it’s OK to post this here.

@steeven @Mattches @SaltyBanana I am comfortable looking at logs, traffic or reproducing stuff if I know where and what to look for. Can I please DM my wallet ID to any of you and have this looked upon?

Something funny definitely going on, ads were working perfectly on Nightly.

Thank you so much for your support and patience.

@Drakkos I am on the latest Release as well and still got the same problem a fresh install did not work either.

I was also having the problem that I was not getting any ads since the new update but today I started getting the sponsored images but not notification ads

@Donkja Homepage ads are also displaying for me. But not adding up BAT estimated earnings neither showing in received ad count.

Do the sponsored images add up to your estimated earnings balance?

Yeah,today they are earning but like 4 or 5 images after that they stop and again after some time 4-5 images.
But I do not get any notification ads.

Yesterday I was not seeing any image or receiving ads.

@Drakkos @eeZee,
We are currently monitoring this situation and believe it may be due to the latest update. To help us out, we’re gathering logs from users to review with the ads team. I’ve sent you both DMs with instructions on how to send use your logs securely.


DM sent, thank you so much!

I getting Image ad but receiving ads still cant coming in

You warning from images cause mine stopped.

ad warning is not working …

What does ad warning mean?

I mean those ad notification is not happening, those image ad now is appearing but click 0 reward given

Same I am also getting 0 rewards for images now and not receiving notification.
My phone was receiving ads but now it receives but bat does not increase.

it work for images ad for less than 1 days, now is not working again OMG

Same here bro I was getting rewards for images yesterday on my laptop but suddenly not anymore and I got like 3 notification ads today.

1 Like

After reinstalling a few times and getting the same result after a few days:

  • No more notifications
  • Sponsored images showing but not adding to earnings
  • Logs showing Response Status Code: 400 Response: "Invalid Request R1" errors

I’ve been told by Mattches

Brave Ads/Rewards are not intended for nor will they work when using virtual machines.

Because I’m on a VM as mentioned in the OP, this post can now be closed as the reason for Rewards not working has been clarified.