After starting ANY download the mouse clicks within the brave browser go dead

After starting ANY download the mouse clicks within the brave browser go dead.

  1. Download ANY file.

  2. During and after the download successfully completes, the mouse clicks within the brave-browser do nothing. Clicking outside the brave window on other applications still work, and the keyboard still works, but the browser itself is non-responsive.

  3. The only way (I have found) to restore normal browser behavior is to reset X11 with

One would not expect the browser to become unresponsive by starting a download.

Brave Browser Version 1.48.171 Chromium: 110.0.5481.177 (Official Build) (64-bit)

1 Like

Hello @BarryMead, thank you for bringing this to our attention. By any chance are you using extensions? If so, try removing some of them since might affect the correct functionality of your mouse. Also try opening a private window to see if the issue persists there. Regards.

I do have a purevpn extension, but I disabled it and the results remain the same.

I don’t know if you can tell by the browser version, but I am running the Ubuntu Linux 22.04 OS and the Linux version of brave.

Do you see this same mouse click dead behavior after a download when your run brave?

One more piece of information that I just recently discovered. The mouse clicks also go dead after starting a file upload as well as download.

The problem persists even with Version 1.49.120 Chromium: 111.0.5563.64 (Official Build) (64-bit). Any file I/O Load/Save Bookmarks, Upload/Download any file. Causes the mouse clicks to go dead. You can’t even close brave-browser with Alt-F4, because that brings up a window requiring a mouse click to close things. I even tried “pkill brave-browser” and that did not restore desktop operation either. The only remedy is a soft (X11) reboot with Ctrl-Alt-Backspace, or full reboot in a terminal with
“sudo reboot”. This needs to be fixed! No more excuses or delays. Don’t neglect the Ubuntu community please!!!

The issue is being caused by a lingering lock file in the .config/BraveSoftware/Brave-Browser/Crash Reports/pending directory. After removing everything in the pending directory, the issue went away. I can now do file I/O without the browser crashing.
You still need to fix this problem, but I can see why your QA team didn’t find it.

1 Like

Someone else also reported a mouse related issue with Brave Beta a year or more back but that issue can’t be replied to any more. Point is I also have a mouse clicks related issue, although in my case there are no files in the Crash Reports sub-folders.

I was busy changing some Appearance settings with Brave Beta and suddenly no mouse clicks worked anywhere inside or outside Brave browser. Even KDE Plasma apps could start with the keyboard but no response with mouse clicks. The mouse cursor moved just fine, but zero response to left or right mouse clicks. I unplugged and plugged the mouse back in, no difference. Keyboard control worked, so I started shutting down Brave Stable, Edge browser, etc. Just after I closed Brave Beta, the mouse clicks suddenly worked again.

So what does Brave do with the mouse control?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.