Newest update broke hardware acceleration

RTX 3070
5600x
x570 chipset
Windows 11
(everything up to date)

Newest update seemed to have broke youtube playback using hardware acceleration. (Insane flickering and distorted artifacts.) Was working as usual until brave just updated.

I’ll just disable it for now until hopefully this gets fixed, but yea just reporting to help the community.

1 Like

Hmm. seems to be working again? I’m not sure what’s going on very confusing. Only thing I did was update ‘chrome’ and when I went back to try brave again it’s working… w/e just adding details lol

1 Like

Seems to be very hard to reproduce what the solution is. Obviously turning off hardware acceleration fixes the video issue… but the hit to performance in normal browsing is pretty significant, enough to push you back to chrome lol.

For those who are suffering similar, changing the brave://flags option “Choose ANGLE graphics backend” to OpenGL seems to fix it, and then make sure you set OpenGL rendering to your nvidia card via the NVIDIA control panel. It’s not perfect, still a lot of hickups but it’s better than letting the CPU do it.

I figured it out! I think! There’s an option in Nvidia Control Panel called ‘Multi-Frame Sampled AA (MFAA)’. It’s disabled by default, but of course I was trying out all the settings on different games. I ended up figuring this out on another program I was having issues with (Exodus Wallet) and figured I would come here and update the solution. I hope this helps someone.

2 Likes