$50 Reward for fix - Upon start, BRAVE works for 3 seconds, then completely FROZEN

Brave has always worked fine, but this morning upon start, it froze after 2 seconds…just long enough to load. Then the screen is frozen and I get the “Braze Not Responding” and I have to close it and try again. What I have tried:

  • I have left it running for hours, still frozen/no change.

  • Restarted Brave many times, but still frozen after the initial start-up loading process (appx two seconds).

  • I have tried to clear the cache upon loading, by hitting shortcut keys CTRL-SHFT-DEL as soon as I open BRAVE, but when the Clear Browsing Data screen pops up, its already frozen.

Interesting note, although I get the “Brave Browser Not Responding” frozen screen, the Windows Task Manager still shows the program as functioning.

Lastly, I have not added or altered any software to my computer for weeks prior to this occurrence. I really need this functioning, as I had not made a back up of bookmarks and passwords in ages…I know that was not smart. Whoever provides the method to get it running, there is $50 for your time.



@taylor5 One thing you haven’t mentioned, can you try opening in a Private Window and advise if it works?

Then after that, can you try to Create a New Profile and see if you have issues there?

To be blunt, usually it’s extensions causing the issue. But the two methods above will be able to test that and kind of filter through a few possible issues. And sadly, just disabling extensions isn’t always enough to make a difference. I never have understood why, but there’s been occasions where people don’t see issue go away until they uninstall extensions.


Good Morning Saoiray,

Thank you for your response and suggestions. I did try the Private Window browser before, but again after a couple of seconds, the browser is frozen.

I like the idea about a new profile, as my only goal is get me bookmarks and passwords. I wish other browsers could load/transfer that data from BRAVE. Chrome, FireFox, Opera, Edge seem to have that functionality with eachother…but sadly, Brave does not.

I will let you know if the profile works…and GLADLY pay you if it does.



maybe try launching with
–disable-extensions commandline flag


Nope… freezes as soon as I get too Create New Profile :frowning:

I was also thinking about downloading and installing an earlies version of Brave, as that might clear the Cache and Data…allowing the program to work. Or an earlier version of Brave that had much more limited Extensions Support, but kept the Bookmarks and Passwords in place.

1 Like

Good Morning Lowner,

Not familiar with that… looking it up.


Thank you Lowner. So first I entered the line to open brave, and it opened and locked again:

“C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe”

Then I tried the Incognito commandline, to make sure I am doing this correctly:
“C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe” --incognito
It opened Brave in Incognito mode, and froze within 2 seconds later. Then I tried disable ALL extensions:
“C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe” --disable-extensions
and it again froze after two seconds. Do you know if there is a way to CommandLine to clear all Browsing Data upon start? Maybe that would work?

1 Like
1 Like

not seeing any flag to clear data or cache.

does it crash if you run as admin?

Run Brave as an ADMIN? Have to look how to do that…

Thank you SmartyAadi; however, Brave freezes as soon as it loads (after 2 seconds). I was able to close one of the two tabs open (just before it freezes), leaving only the bookmarks TAB open. then it freezes. I forced closed, then reopened with ONLY the bookmarks TAB opening…and it freezes again with two seconds.

When you search for brave using Windows key, there should be an option there.

Can you check to see if there are any crashes reported using the following:

C:\Users[user]\AppData\Local\BraveSoftware\Brave-Browser\User Data\Crashpad

right click icon choose run as administrator

Also, could you try renaming brave.exe as something else ?
Had read this helped a while ago when someone was having this issue.

Good Afternoon… yes it continues to freeze when I run as ADMIN…after 2 seconds, when the initial page is loading.

Thank you VERY much for showing where the ADMIN option was, as it was very helpful. Unfortunately, it still freezes, just like it was opened normally.

Holy Humpers, there is a ton of stuff in this folder. I wonder if I could delete the Cache and extensions in here, it would solve this? Hang on, I am providing an image of what’s in here.