Brave has slowed down and freezes

Brave has slowed down and freezes very frequently for 2-4 seconds or more. I didn’t change anything and is not my computer because everything works except Brave.

How can this issue be reproduced?

  1. I don’t know because it doesn’t freeze systematically but randomly

Expected result:

Brave Version:

1 Like

Thanks for reaching out.
Has this always happened since Brave was installed? Additionally, can you tell me what Windows version you’re using, as well as if you have any extensions installed at this time?

Hi, it has been happening for about a week.
Windows version is: Windows 10 Home 21H1
Now I have MetaMask and Google translate, 2 weeks ago I installed and removed it when brave started freezing.

You removed Grammarly entirely? That particular extension has been known to cause conflicts/issues in the browser. Can you please try creating a fresh browser profile and test to see if the browser still freezes when using it? Please ensure you close the original browser window you had open – such that only the browser window with the new profile is running when performing this test.

I created a new profile but it still freezes

Hm – so in your original profile, can you try disabling Hardware Acceleration in settings to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

I will join this thread because a week ago it started to freeze for me as well.
I think it’s only in the game I play. FoE.
As you say, for a few seconds and then it continues.
Same ver. Brave , windows Pro 20H2

Done, but it still the same :frowning:

I am getting this issue too. I’m not doing anything computationally taxing, just browsing the internet and running discord - the only thing that freezes (as described in OPs post) is brave. This issue is costing me money as I run business from brave browser. Seems to have only been happening since I upgraded to latest Brave version (maybe?).

1 Like

Now works!!! It was “Hardware Acceleration” because I tried to enable and it started freezing back, thanks a lot for the support.

1 Like

Please try the same tests/solutions I asked above and report your findings.

That will not work for me as the games plays very slow like that.
This is not an action game, I am just talking about loading images , pages.
So I guess we learned that in the last update they messed up the hardware acceleration.
Rollback/downgrade would be nice about now.

Can you please tell me/share the link to the game you’re referring to?

FoE Forge of Empires, just a browser game.

The startup(browser) is also slow. That may be the 14 tabs, plus the other processes, but that is the only other place I see slowdown. That only at first start after the starting the computer.

Yeah so this game seems to run just fine on my end on both Windows and macOS systems. I’m wondering if you have any other extensions installed at this time? One of them may be causing the slowdown. Additionally, it would be worth testing in a private browsing window to see if you get the same behavior.

First, I ran it in Private window and the problem is still there.
You say it runs fine for you, remember this only started a few weeks ago.
The second thing is something I wrote about in my other post, that in order to ease the load, I created a second profile just for the game and got surprised when I looked at the task manager and all the processes (including extensions) were still running in the bare profile.
Even more surprising that everything is still loaded in the private window ! Why is that !?

You’re saying that if you open only one window – with your second/new profile – it still shows all extensions/processes from what’s in your original profile?

Yes, it’s in my other post and this picture was when just the private window was open.

Other. Today I logged into google mail on my browser and could not download a file from drive that I just uploaded from my tablet. It said something about 3rd party cookies. When I am logged into my own account I can’t download my file?
Have you read anything about this today?

1.27 so good version, 1.28 so hard for Ram

I finally disabled some extensions and that seems to helped with the game.
The problem may be the Speed Dial extension.
Which is very disappointing as I have spent months to set it up the way I like it and now it causes problems. Maybe too many tabs , I don’t know. As everything gets updated, at that point who knows what is the problem.
I do like speed dials much more than bookmarks. :frowning:
The one I am using.