Brave Browser not responding when opened

1.the problem happen every time when i opening brave browser will not responding up to 2-3 minute and cannot click anything when it happen.
3.after that it will become normal

Brave version : 1.7.98

update :-

found the solution on other thread


Many users have been reporting the same problem. You can check the issue on their github here:

If it’s possible, please share your minidump with them. You can follow the posted instruction there.

I have the same problem of Brave crashing (started being unrecoverable a couple days ago- Using Win 10):
Not opening fully; get "Restore Pages? then "Brave (Not Responding); NEVER comes on;
It was taking several minutes to load a week or 2 before it be come completely unresponsive.
Reinstalled with latest version: No change - still not responsive after blank screen opens.

I have also tried opening shortcut with " --disable-gpu" added, but No help.

Can you try the solution in the following thread and see if it resolves the issue for you?

Guess I’ll check back next year to see if one of your users figured out how to fix it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.