Youtube "play on TV" Icon Missing

I run W10 desktop with Edge, Chrome, Brave, and Firefox browsers. On the Edge and Chrome browsers, when I start a vid on www.youtube.com, I can see the youtube icon that I can click on to play the video on any of my 3 TV’s. On Brave and Firefox, the “play on TV” youtube video icon is missing. Is there a way to get that icon to appear on the 2 browsers that do not have it?

@cwr64,
For Brave, you’ll need to ensure you have the following option enabled in Settings --> Extensions:

This is what worked for me:

For Brave browser do the following:
Open the browser and in the address link type: brave://flags and press Enter;
In the search field type: load-media-router-component-extension press Enter;
When located, go to Default, click on it and change to “Enable”;
Close and open the browser;
Go to youtube and you will see the option “Play on TV” at the bottom of the video;

For Firefox:
Open your browser and address bar and paste the link: https://hensm.github.io/fx_cast/ press Enter;
Click Firefox Extension and install the extension, clicking Add at the end;
Restart the browser and you will see the extension enabled beside the three bars in the upper right corner, where you will be able to transmit the screen to the TV;

@cwr64,
The option that I pointed out in Settings --> Extensions toggles the very same flag you’re referring to.