Youtube hardware accelerated decoding is slow in brave, but not other browsers

Description of the issue:
Watching youtube videos in Brave, the player is slow and the video is choppy with many dropped frames. This is with hardware acceleration ENABLED. Disabling hardware acceleration will result in smooth video playback except in 8k videos where my cpu can’t keep up and choppy video returns. Other browsers such as Chrome and Edge have no issues whatsoever (nor should they, I have a perfectly capable graphics card).

How can this issue be reproduced?

  1. Enable hardware acceleration
  2. Watch any 4k youtube video
  3. Observe choppy video and laggy player controls

Expected result:
Smooth playback.

Brave Version( check About Brave):
1.26.67
Additional Information:
Windows 10 21H1
AMD Ryzen 7 5800X CPU
NVIDIA RTX 3080 Graphics card

2 Likes

What system resources does More ToolsTask Manager show?

Hmm doesn’t look too bad. If you right-click on the video, stats for nerds. Any dropped frames?

Yes, many dropped frames every second. Also just scrolling the page or moving the mouse over the player controls is extremely slow and choppy.

Seems like this is affecting everything that uses hardware acceleration, even clicking the recent tabs button in the top right is stuttery unless I disable hardware acceleration.

Any reason this might be happening? I tried a new windows install, did not help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.