YouTube Ads not getting blocked by Shields (Desktop/Mobile)

shields
bug
#1

Description


We’ve observed user reports recently claiming that YouTube ads are bypassing Shields. This is seemingly not limited to any one type of ad on the page - users have reported:

  • YouTube pre-roll ads (that play before selected video content plays)
  • Ad overlays (ads that appear overlay/sit on top of the media player, even after streaming desired content)
  • Ads on page (tend to appear on right-hand side of page, above “related/suggested” videos)

Status


I have opened an issue to capture this error on our GitHub which can be tracked here:


As it stands (at time of opening this thread, 2019-02-21T08:00:00Z) we’re looking for any additional information that may be relevant in diagnosing this behavior. Note that not all users have this issue and it doesn’t seem specific to any one OS so getting the appropriate/relevant information on this can be tricky.

If you came here (or were linked to/redirected here) to report seeing ads on YouTube, please make sure you fill out/provide the requested info in the issue template that appears in the editor for this category so pertinent information is easily visible for our developers to look at.

Note: For this issue in particular, please be specific about whether you’re seeing ads on the Desktop or Mobile browser.

Related Threads

(All recently created topics referencing this issue that are now closed in favor of this one)


Recently i discoverd that i am seeing ads on youtube again
Still getting ads on youtube, not sure how to enable regional adblock
Brave Shields not working even when turned on

0 Likes

Brave Shields not working even when turned on
Brave Shields not working even when turned on
Recently i discoverd that i am seeing ads on youtube again
Still getting ads on youtube, not sure how to enable regional adblock
#2

On all of the big websites such as Youtube, Outlook and even News sites i get ads and other unwanted junk even when my shields are on. it happens on everything that i can think of.

2019-02-12T18:07:00Z
1 2
This just started today and i have no idea how to fix it, is this a bug or has something gone wrong? please let me know thanks.

0 Likes

#3

@Carpy,
Thanks for reaching out with this. These ads should definitely be blocked. I’ll be opening an issue for this by the end of the day to capture this data.
Would you mind telling me which version of Brave you’re using as well as your OS?

0 Likes

#4

Version 0.59.35 Chromium: 72.0.3626.81 (Official Build) (64-bit) Windows 7 Ultimate 64-bit

1 Like

#5

Thank you - appreciate the info. I’ll return here and reply with the issue once it’s filed. Thanks again for bringing this to our attention.

0 Likes

#6

With apologies and respect to OP, FWIW, same build on MacOS X 10.14.3 appears to block successfully on YouTube.com (not signed in and signed in).

2 Likes

#7

:point_up: This is precisely why we ask so many questions with respect to your (the users) setup when reporting bugs. I too see pre-roll and on-page ads blocked here, but I’m on macOS. The issue may be specific to Windows.

I’m discussing with some team members now and will again return when I have an issue logged.

0 Likes

#8

Now that i have “some shields” the ads are still playing

0 Likes

#9

I’ve opened an issue for this because, unless I’m misinformed, I don’t believe you should be seeing any of the ads appearing. I appreciate you bringing this to our attention. You can track the issue here:

0 Likes

#10

@Carpy,
Is there any chance you’d be willing to submit a short screen recording of this? Just visiting YT and attempting to stream video content.

0 Likes

#11

Strangely today the shields are blocking both ads and trackers and i have no idea what fixed what.

The only minor problem i’m having now is i can’t make Brave the default browser

0 Likes

#12

Did you clear your browsing data/cache or anything?

0 Likes

#13

I cleaned my browsing data when i had the problem and it still persisted so i have no clue, sorry for the little help

0 Likes

#14

I am also having this issue but not only I am seeing ads on Youtube videos I am seeing ads on Startpage and various other websites. Brave Shields were working perfectly fine yesterday and today they seem to be not blocking most ads.

0 Likes

#15

The ads are rampant on Youtube using the Brave browser. Sometimes a couple minutes long without the ability to skip. I even disabled the ad block feature and still get ads. Youtube has enabled the f**k you for using the Brave browser filter. I had to turn away from YT For the time being until there is a fix.

0 Likes

#16

@ChuckMCCluck, @lunarsedge,
Thank you for letting us know - would you mind telling us whether you’re on desktop or mobile and which OS you are using for either?

0 Likes